HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (
-   Installation/Configuration (
-   -   ISPconfig/ Postfix forward (

nemo12 15th March 2006 10:24

ISPconfig/ Postfix forward
I have ispconfig installed and there is site: What I need is all this mail, whitch users are in ispconfig, are comeing to this server to their mailboxes and all mail, whitch users aren't in users table goes to another server(like mailscanner). till today I used for it transport_maps in postfix, but ISPconfig looks for e-mails before it and inf no alias in user table then says no user.

what could be the solution?

falko 15th March 2006 13:37

You could create a catch-all account and then try to forward these emails (e.g. with the forward field in ISPConfig or with transports).

nemo12 15th March 2006 13:43

I other server I haver running mail filter with that configuration.

plus I added transport_map :next smtp server.

All aadresses whitch are not in aliases base are transported to next smtp server.

But with ispconfig it does not work.

nemo12 15th March 2006 13:54

jeah, got the point. just catchAll-Email needed and transport mapping works :)

nemo12 15th March 2006 14:51

it wasn't so easy.

I don't know why, but after that I once checked catch all mail, transport maps got working. if I uncheck catch all, transport maps still working - thats good :)

but now - it sends all mail to next smtp server even these what are in ispconfig.

falko 15th March 2006 18:48

What did you put into /etc/postfix/transport?

nemo12 15th March 2006 20:21 smtp:nextsmtpserverip

falko 15th March 2006 23:34

Please put the catch-all email address into the transports table instead:

Code: smtp:nextsmtpserverip

nemo12 16th March 2006 13:06

not working - sends all mail to with same name as catch all accout. I need people in other server get their mails to own mailbox.

I think it is quite logic that - postfix checks users tables and if there is no user sends mail to next smtp - or it isn't so easy? this means actually ispconfig doesn't need to confuse situation - postfix just checks users table and sends all unknown to next smtp.

nemo12 16th March 2006 17:19

again myself - maybe it helps.

In my other server I have configured:

virtual_alias_maps = mysql:/etc/postfix/
virtual_gid_maps = static:1001
virtual_mailbox_base = /home/virtual
virtual_mailbox_domains = mysql:/etc/postfix/
virtual_mailbox_maps = mysql:/etc/postfix/
virtual_mailbox_limit = 51200000
virtual_minimum_uid = 1001
virtual_transport = virtual
virtual_uid_maps = static:1001

at first it looks to the virtual alias table and if user unknown uses transport_map.

ispconfig needs that users are in local tables and domains are in mydestination. thats why I get local user unknown.

is any idea how to hack this?

All times are GMT +2. The time now is 09:00.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.