HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Hell of asp debian apache (http://www.howtoforge.com/forums/showthread.php?t=3129)

ColdDoT 15th March 2006 08:33

Hell of asp debian apache
 
Hello

i want to offer my customers asp i know that it can i've you pay chilisoft. but first i will try how much poeple uses asp so i want to set up apache::asp

i've installed apache::asp but now i must install mod_perl and that i can't get it work i get over and over again compile errors this is what i use

apache 2.2
perl 5.8.8
mod_perl 2.0.2

this are the compile commands i use

#perl Makefile.PL MP_APXS=/var/server/webserver/apache/bin/apxs MP_APR_CONFIG=/var/server/webserver/apache/bin/apr-1-config
GOOD
(but i get this note)
Note (probably harmless): No library found for -lperl

#make
GOOD it says but i get almost only
/usr/lib/perl/5.8/CORE/proto.h:2010: let op: `warn_unused_result' attribute directive ignored
and the proto.h:**** is changing all the time

#make test (there the problem starts i get this)
/usr/bin/perl -Iblib/arch -Iblib/lib \
t/TEST -clean
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl /var/server/webserver/mod_perl-2.0.2/t/TEST -clean
APACHE_TEST_GROUP= APACHE_TEST_HTTPD= APACHE_TEST_PORT= APACHE_TEST_USER= APACHE_TEST_APXS= \
/usr/bin/perl -Iblib/arch -Iblib/lib \
t/TEST -bugreport -verbose=0
[warning] setting ulimit to allow core files
ulimit -c unlimited; /usr/bin/perl /var/server/webserver/mod_perl-2.0.2/t/TEST -bugreport -verbose=0
[warning] root mode: changing the files ownership to 'nobody' (65534:65534)
[warning] testing whether 'nobody' is able to -rwx /var/server/webserver/mod_perl-2.0.2/t
"/usr/bin/perl" -Mlib=/var/server/webserver/mod_perl-2.0.2/Apache-Test/lib -MApache::TestRun -e 'eval { Apache::TestRun::run_root_fs_test(65534, 65534, q[/var/server/webserver/mod_perl-2.0.2/t]) }';


[warning] result: OK
[warning] the client side drops 'root' permissions and becomes 'nobody'
/var/server/webserver/apache/bin/httpd -d /var/server/webserver/mod_perl-2.0.2/t -f /var/server/webserver/mod_perl-2.0.2/t/conf/httpd.conf -D APACHE2 -D PERL_USEITHREADS
using Apache/2.2.0 (prefork MPM)

waiting 120 seconds for server to start: .httpd: Syntax error on line 16 of /var/server/webserver/mod_perl-2.0.2/t/conf/httpd.conf: Cannot load /var/server/webserver/mod_perl-2.0.2/src/modules/perl/mod_perl.so into server: /var/server/webserver/mod_perl-2.0.2/src/modules/perl/mod_perl.so: undefined symbol: PL_ppaddr
[ error]
server has died with status 255 (t/logs/error_log wasn't created, start the server in the debug mode)
sh: line 1: 15239 Afgebroken /usr/bin/perl /var/server/webserver/mod_perl-2.0.2/t/TEST -bugreport -verbose=0
make: *** [run_tests] Fout 143


greets kevin

till 15th March 2006 08:49

Is there a special reason why you dont use the DEBIAN mod_perl package?

ColdDoT 15th March 2006 14:15

//EDIT
nvm after i update it all my packages it works all fine now


All times are GMT +2. The time now is 18:43.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.