HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Fedora 10 Apache2 WebDAV (http://www.howtoforge.com/forums/showthread.php?t=30851)

progkix 2nd February 2009 15:10

Fedora 10 Apache2 WebDAV
 
I've followed the steps outline in the article about setting up WebDAV in Apache2 on Fedora 10 but I'm not having any luck in successfully testing it.

The dav and dav_fs modules are enabled in httpd.conf.

Here's the VirtualHost segment from httpd.conf:

<VirtualHost *:80>
DocumentRoot /var/www/web/dav/
ServerAdmin webmaster@sdps-bbs.com
<Directory /var/www/web/dav/>
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Alias /webdav /var/www/web/dav

<Location /webdav/>
DAV On
AuthType Basic
AuthName "WebDAV Restricted"
AuthUserFile /var/www/web/passwd.dav
Require valid-user
</Location>
</VirtualHost>

And here's the output from the cadaver test:

csmith@lnx7 : ~ ==> cadaver http://localhost/dav
Could not access /dav/ (not WebDAV-enabled?):
405 Method Not Allowed
Connection to `localhost' closed.


Any clues or ideas would be greatly appreciated.

Thanks in advance

Charlie Smith

falko 3rd February 2009 19:49

Do you have any other vhosts in your Apache configuration, or is this the only one?

progkix 3rd February 2009 21:19

Falko,

I have 3 or 4 other vhosts in my Apache configuration.

Charlie

falko 4th February 2009 17:38

Make sure that the WebDAV vhost is listed as the first one in your Apache configuration, or add a ServerName directive to it.

progkix 4th February 2009 18:11

Moved it to the top of the vhost list but that made my main site inaccessible.

Also tried giving it a ServerName directive and that didn't work either.

Thanks

falko 5th February 2009 20:47

Can you post your vhost configurations here?

progkix 6th February 2009 03:18

# main site
<VirtualHost *:80>
ServerName www.sdps-bbs.com
DocumentRoot /var/www/html
ServerAdmin webmaster@sdps-bbs.com
</VirtualHost>

# virtual host test
<VirtualHost *:80>
ServerName www.virt.sdps-bbs.com
DocumentRoot /var/www/virt
ServerAdmin webmaster@sdps-bbs.com
ErrorLog logs/virt-error_log
TransferLog logs/virt-access_log
</VirtualHost>

# social application test
<VirtualHost *:80>
ServerName www.cyberfun.sdps-bbs.com
DocumentRoot /var/www/elgg
ServerAdmin webmaster@sdps-bbs.com
ErrorLog logs/elgg-error_log
TransferLog logs/elgg-access_log
<Directory /var/www/elgg>
AllowOverride All
</Directory>
</VirtualHost>

# four sisters web site
<VirtualHost *:80>
ServerName www.foursisters.sdps-bbs.com
DocumentRoot /var/www/yarbro
ServerAdmin webmaster@sdps-bbs.com
ErrorLog logs/yarbro-error_log
TransferLog logs/yarbro-access_log
</VirtualHost>

# internet radio broadcasting
<VirtualHost *:80>
ServerName www.radio.sdps-bbs.com
DocumentRoot /var/www/radio
ServerAdmin webmaster@sdps-bbs.com
ErrorLog logs/radio-error_log
TransferLog logs/radio-access_log
</VirtualHost>

# webdav
<VirtualHost *:80>
DocumentRoot /var/www/web/dav/
ServerAdmin webmaster@sdps-bbs.com
<Directory /var/www/web/dav/>
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Alias /webdav /var/www/web/dav

<Location /webdav/>
DAV On
AuthType Basic
AuthName "WebDAV Restricted"
AuthUserFile /var/www/web/passwd.dav
Require valid-user
</Location>
</VirtualHost>

falko 6th February 2009 19:10

Add
Code:

ServerName localhost
to the WebDAV vhost and check if the cadaver thing is working then.

progkix 7th February 2009 16:01

Woohoo - it does work.

I love HowtoForge. I get so much excellent help here. I'm glad I decided to pay up!

Many thanks once again.

Charlie

falko 8th February 2009 19:41

If you want to connect from outside, you must also add a hostname that is accessible from outside with a ServerAlias directive:
Code:

ServerAlias webdav.example.com


All times are GMT +2. The time now is 22:44.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.