HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Gallery2 Permalinks (mod_rewrite) on ISPConfig with Multi-site installation (http://www.howtoforge.com/forums/showthread.php?t=30726)

DantePasquale 28th January 2009 19:15

Gallery2 Permalinks (mod_rewrite) on ISPConfig with Multi-site installation
 
Hi,

I have Gallery2 running with latest stable ISPConfig on Ubuntu 8.10-64 AMD. Everything works fantastic. Except that I want to enable permalinks for many reasons.

I downloaded and installed Gallery's Permalink plugin. The problem is that when I enable that plugin with any options checked, no web pages are found. But, if I clear all the options, save it, then things are back to normal.

This creates a .htaccess in /var/www/web9/web/gallery directory. The codebase is in /var/www/web2/web.

I'm not sure, but I think that with ISPConfig I need to add some sort of <Directory> directive in the Apache Directives Optional Screen for that web-site.

Anyone else run into this? What solutions worked for you?

Dante

BTW, here's the .htaccess file generated by Gallery2 Permalinks Plugin:

Code:

# BEGIN Url Rewrite section
# (Automatically generated.  Do not edit this section)
<IfModule mod_rewrite.c>
    Options +FollowSymlinks
    RewriteEngine On

    RewriteBase /gallery/

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d [OR]
    RewriteCond %{REQUEST_FILENAME} gallery\_remote2\.php
    RewriteCond %{REQUEST_URI} !/gallery/main\.php$
    RewriteRule .  -  [L]

    RewriteCond %{HTTP:Authorization} (.+)
    RewriteCond %{QUERY_STRING} !g2_authorization=
    RewriteRule .  %{REQUEST_URI}?g2_authorization=%1  [QSA]
    RewriteCond %{REQUEST_METHOD} OPTIONS
    RewriteRule .  http://gallery.cocoanet.us/modules/webdav/data/options/  [QSA,L]
    RewriteCond %{THE_REQUEST} /gallery/d/([0-9]+)-([0-9]+)/([^/?]+)(\?.|\ .)
    RewriteCond %{REQUEST_URI} !/gallery/main\.php$
    RewriteRule .  /gallery/main.php?g2_view=core.DownloadItem&g2_itemId=%1&g2_serialNumber=%2&g2_fileName=%3  [QSA,L]
    RewriteCond %{THE_REQUEST} /gallery/v/([^?]+)\.davmount(\?.|\ .)
    RewriteCond %{REQUEST_URI} !/gallery/main\.php$
    RewriteRule .  /gallery/main.php?g2_view=webdav.DownloadDavMount&g2_path=%1  [QSA,L]
    RewriteCond %{THE_REQUEST} /gallery/w(/[^?]*)?(\?.|\ .)
    RewriteCond %{REQUEST_URI} !/gallery/main\.php$
    RewriteRule .  /gallery/main.php?g2_controller=webdav.WebDav&g2_path=%1  [QSA,L]
    RewriteCond %{THE_REQUEST} /gallery/v/([^?]+)(\?.|\ .)
    RewriteCond %{REQUEST_URI} !/gallery/main\.php$
    RewriteRule .  /gallery/main.php?g2_path=%1  [QSA,L]
</IfModule>

# END Url Rewrite section


till 29th January 2009 11:03

This rewrite code should work in a .htaccess file, no need to add it in the apache directives field. Is gallery2 installed directly in the "web" directory or in a subdirectory "web/gallery"? If its installed directly in the web directory, the line:

RewriteBase /gallery/


has to be:

RewriteBase /

DantePasquale 29th January 2009 15:27

Hi Till,

Gallery is installed under web/gallery. Yeah, the re-write code looks fine, but it's not finding the pages when I have this file in place.

It's actually a bit weirder than that. Let's say I open the main gallery, it opens fine, but none of the pictures are displayed. When I look at their URL's they are indeed rewritten.

What's a good way to debug this?

Thanks, Danté


All times are GMT +2. The time now is 03:42.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.