HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Server can't "see" the internet (http://www.howtoforge.com/forums/showthread.php?t=306)

Luciano 17th August 2005 19:45

Server can't "see" the internet
 
Hi folks! :D

Probably this may be a common error, caused by a little mistake of myself during the installation process. Please let me know what's going wrong.
This problem is similar as what i found on this thread: http://www.howtoforge.com/forums/sho...ighlight=relay

When i try to send a mail via Uebimiau, inside ISPConfig, i receive this error:

Quote:

It was not possible to send this e-mail
SMTP Error: Recipient not accepted. Verify your relay rules
I verified my DNS settings on my DNS server, and everything is fine. The DNS server finds the mail server without a problem. My .zone file on the DNS server shows:

Quote:

MX 5 smtp.e4w.com.br. ---> Our mailboxes actually are hosted on an external ISP.
MX 10 darwin.e4w.com.br. --> This is our internal mail server.
I asked a friend to test if he can "see" the mail server from outside my network. After using the command

Code:

ping mail.valeresponde.com.br
This result appears:

Code:


Starting against mail.valeresponde.com.br [200.190.167.101]
with 32 bytes of data:
 
Request server timeout
Request server timeout
Request server timeout
Request server timeout
 
Statistics of Ping to 200.190.167.101:
Packets: Sent = 4, Received = 0, Lost = 4 (100% of lost)

Probably something is blocking the transmission/receiving of packets from/to my network. What will i have to do? Shall i have to change settings of my DNS server? Or the problem might be the firewall? :rolleyes: :confused:

Any help it's welcome! :D

jnoble 17th August 2005 21:16

first thing to check
 
Hello, the first thing I would check is that your using your internal mailserver to send out (best practice) and if not, then the external mailserver has to allow relay from you.

The headers of the rejection email will say which server it is trying to use.

James

domino 17th August 2005 23:51

I'm having a bit of problem receiving, but I think it's my config setting at my DNS service. The first thing I did to be able to send was open port 110 and 25 on my AP router as well as my DSL modem.

These might be able to help you troubleshoot your configuration.

Email/SMTP Test Utility: http://www.zoneedit.com/smtp.html
Mailbox/POP3 Test Utility: http://www.zoneedit.com/pop3.html?ad=smtptest
NSLookup: http://www.zoneedit.com/lookup.html?ad=pop3test

till 18th August 2005 10:51

Quote:

Originally Posted by Luciano
When i try to send a mail via Uebimiau, inside ISPConfig, i receive this error:

Do you have these lines in your postfix main.cf?

Code:

mynetworks = 127.0.0.0/8
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains


Luciano 18th August 2005 19:40

Is there a little point that i'm missing? :D
 
Hi Till !

I've checked the /etc/postfix/main.cf file, just as you said, and i've found two things:

1 - I didn't find the statement mynetworks = 127.0.0.0/8 in the TRUST AND RELAY CONTROL section. So, i've added it.

2 - Then, i've searched for the smtpd statement and i've found this line below:

smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination

which is straightly different than your hint mentioned before:

smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains

Does the lack of these two parameters is the main reason for the mail server failure? :confused:


In addition, i've also checked the log for e-mails, in /var/log/maillog. And, between the most error messages, one of them is very common: Network is unreachable.

Take a look and tell me, please, what i'm missing here. :D

Aug 18 12:12:24 darwin postfix/smtp[24537]: connect to uipa01i82.usiminas.com.br[200.251.3.175]: Network is unreachable (port 25)
Aug 18 12:12:24 darwin postfix/smtp[24537]: connect to uipa01m10x.usiminas.com.br[200.251.3.249]: Network is unreachable (port 25)
Aug 18 12:12:24 darwin postfix/smtp[24537]: 8F01013A8067: to=<vdesouza@usiminas.com.br>, relay=none, delay=11930, status=deferred (connect to uipa01m10x.usiminas.com.br[200.251.3.249]: Network is unreachable)
Aug 18 12:12:24 darwin postfix/smtp[24536]: connect to smtp.gerdau.com.br[200.213.29.36]: Network is unreachable (port 25)
Aug 18 12:12:24 darwin postfix/smtp[24536]: connect to smtp.gerdau.com.br[200.213.29.35]: Network is unreachable (port 25)
Aug 18 12:12:24 darwin postfix/smtp[24536]: 7039013A8066: to=<hugo.freitas@gerdau.com.br>, relay=none, delay=11930, status=deferred (connect to smtp.gerdau.com.br[200.213.29.35]: Network is unreachable)
Aug 18 12:12:40 darwin postfix/smtp[24538]: connect to mail.valeresponde.com.br[200.190.167.101]: Network is unreachable (port 25)
Aug 18 12:12:40 darwin postfix/smtp[24538]: D812E13A8064: to=<valeresponde@valeresponde.com.br>, relay=none, delay=76968, status deferred (connect to mail.valeresponde.com.br[200.190.167.101]: Network is unreachable)
Aug 18 12:29:04 darwin postfix/qmgr[9006]: 57BCD13A805E: from=<e4w@e4w.com.br>, size=1147, nrcpt=1 (queue active)
Aug 18 12:29:04 darwin postfix/smtp[24874]: connect to smtp.e4w.com.br[200.150.150.17]: Network is unreachable (port 25)
Aug 18 12:29:04 darwin postfix/smtp[24874]: 57BCD13A805E: to=<tecnologia@e4w.com.br>, relay=none, delay=91746, status=deferred (connect to smtp.e4w.com.br[200.150.150.17]: Network is unreachable)

Thanks in advance!!

falko 18th August 2005 20:24

Quote:

In addition, i've also checked the log for e-mails, in /var/log/maillog. And, between the most error messages, one of them is very common: Network is unreachable.
Can you ping the outside world? Try
Code:

ping -c4 www.google.com

Luciano 22nd August 2005 16:10

The result is...
 
This is the result:

Code:


# ping -c4 www.google.com
 
PING www.l.google.com (64.233.167.99) 56(84) bytes of data.
 
 
--- www.l.google.com ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 2999ms


falko 22nd August 2005 16:34

Your system doesn't have a connection to the internet! :( Not very good for sending mails... :D

jrowe 22nd August 2005 23:22

Perhaps a slight oversight but it appears that you were trying to ping www.google.com and could not ping it, it could have to do with your ISP blocking pings, I cannot ping it myself from work, ICMP to the net is blocked, but from home (verizon DSL) I can ping it. Just thought i'd help. Have a nice day!



Quote:

Originally Posted by Luciano
This is the result:

Code:


# ping -c4 www.google.com
 
PING www.l.google.com (64.233.167.99) 56(84) bytes of data.
 
 
--- www.l.google.com ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 2999ms




All times are GMT +2. The time now is 13:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.