HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   fail2ban not working (http://www.howtoforge.com/forums/showthread.php?t=30581)

linuxwannabe 24th January 2009 05:37

fail2ban not working
 
After installing ispconfig, fail2ban stopped working, it starts but,

4302 pts/0 00:00:00 fail2ban-client
4303 pts/0 00:00:00 fail2ban-server <defunct>

This is a fresh install on a new hard drive.

1. OpenSuse 11.1, the perfect server setup with Kde 4
2. Online update
3. postgrey
4. fail2ban
5. ispconfig
6. phpmyadmin
7. UebiMiau

I installed everything up to fail2ban and it was all working.
Then after installing ispconfig, I noticed fail2ban was not working.
I tried uninstall, reinstall fail2ban, didn't help.
I use yast for the installs.
I tried shutting down almost all the services, then uninstall, install, start,
but still no luck.
There is nothing going into the logs when I start it.
I tried strace, and I don't see anything wrong there.
The uninstall, install puts back the default config file, so it can't be that.

Any ideas??

Should I go back to OpenSuse 10.3?

Does anyone have this working?
OpenSuse 11.1
fail2ban
ispconfig
??

linuxwannabe 25th January 2009 06:09

fixed it
 
I got it working, I'm so happy!
There was something wrong with the
fail2ban.sock
file, so I ran
fail2ban-server -x
then it started working again.
I don't think ispconfig had anything to do with
fail2ban not working, it just looked that way at the time.


All times are GMT +2. The time now is 07:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.