HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   bind9 don't restart : rndc: connect failed: connection refused (http://www.howtoforge.com/forums/showthread.php?t=3047)

burtathis 11th March 2006 14:14

bind9 don't restart : rndc: connect failed: connection refused
 
Hello there !

I was so proud with my own DNS working well for 2 days but recently when i restarted the computer,
the bind9 didn't restart !

When i make
Code:

/etc/init.d/bind9 restart
it shows this :

Code:

* Stopping domain name service...
rndc: connect failed: connection refused
  ...done.
 * Starting domain name service...
  ...done.

One clue is that i changed the certificates like in this Falko's explanations :
http://www.howtoforge.com/forums/sho...hlight=openssl

Does it deals with that or any authorisations settings ? :rolleyes:

One more thing : i had a dyndns name (burtnet.dyndns.org) that i abandon in those last days and when i connect the ispconfig interface : it doesn't load pages well and still make reference of this dyndns url in spite of having my new domain inside my /home/admispconfig/ispconfig/lib/config.inc.php :
Code:

$go_info["server"]["server_url"] = "https://petiteboitesansfond.net:81/";
thanks guys !

falko 11th March 2006 21:31

Quote:

Originally Posted by burtathis
Hello there !

I was so proud with my own DNS working well for 2 days but recently when i restarted the computer,
the bind9 didn't restart !

When i make
Code:

/etc/init.d/bind9 restart
it shows this :

Code:

* Stopping domain name service...
rndc: connect failed: connection refused
  ...done.
 * Starting domain name service...
  ...done.

One clue is that i changed the certificates like in this Falko's explanations :
http://www.howtoforge.com/forums/sho...hlight=openssl

Does it deals with that or any authorisations settings ? :rolleyes:

Have a look at the comments below this tutorial: http://www.howtoforge.com/howto_bind_chroot_debian
Must be a permissions problem...

Quote:

Originally Posted by burtathis
One more thing : i had a dyndns name (burtnet.dyndns.org) that i abandon in those last days and when i connect the ispconfig interface : it doesn't load pages well and still make reference of this dyndns url in spite of having my new domain inside my /home/admispconfig/ispconfig/lib/config.inc.php :
Code:

$go_info["server"]["server_url"] = "https://petiteboitesansfond.net:81/";
thanks guys !

Search for your old domain in /root/ispconfig/httpd/conf/httpd.conf, change it and restart ISPConfig:
Code:

/etc/init.d/ispconfig_server restart

VMartins 9th October 2006 15:16

Problem with RNDC Connection Refused...
 
Hello Falko,

I have the same problem:

* Stopping domain name service...
rndc: connect failed: connection refused
...done.
* Starting domain name service...
...done.

I follow your guide to install ISPConfig in Ubuntu. I verified my chroot bind installation, and nohing wrong.

Do you have another tip?

Thanks,

Vinicius

falko 10th October 2006 14:21

Have a look at the comments below http://www.howtoforge.com/howto_bind_chroot_debian . It'S a permissions problem.

VMartins 10th October 2006 15:04

Thanks falko,

In this moment I wrote a answer in other Thread (http://www.howtoforge.com/forums/sho...4118#post44118)

I search in Google and I find the command named -g -p 53 to test my named.conf syntase and found one error, I correct it in the named.conf.master. I restart my bind service and the problem with rndc is gone. I can't figure out what happend.

What do you think?

Bye,

Vinicius


All times are GMT +2. The time now is 12:11.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.