HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Can Send Email, But Not Recieve; Relay access denied (http://www.howtoforge.com/forums/showthread.php?t=3023)

jazzgillum 9th March 2006 23:14

Can Send Email, But Not Recieve; Relay access denied
 
Hi,

I'm stuggling to get ISPConfig up and running. I followed the Ubuntu Perfect Setup. When I send test emails to user accounts that I have set up, I quickly get a bounce message back. Here's the complaint in the return mail:

PERM_FAILURE: SMTP Error (state 9): 554 <test@mydomain.dom>: Relay access denied

I've searched this forum and found lots of similar problems, but mostly about SENDING mail rather than RECEIVING it. I've tried some of the solutions suggested in the similar topics, but nothing has worked, so its possible that I've messed things up worse.

Again, I can send emails, but not recieve. Any help would be appriciated!

edge 10th March 2006 00:14

Quote:

Originally Posted by jazzgillum
Hi,

I'm stuggling to get ISPConfig up and running. I followed the Ubuntu Perfect Setup. When I send test emails to user accounts that I have set up, I quickly get a bounce message back. Here's the complaint in the return mail:

PERM_FAILURE: SMTP Error (state 9): 554 <test@mydomain.dom>: Relay access denied

I've searched this forum and found lots of similar problems, but mostly about SENDING mail rather than RECEIVING it. I've tried some of the solutions suggested in the similar topics, but nothing has worked, so its possible that I've messed things up worse.

Again, I can send emails, but not recieve. Any help would be appriciated!

I've had exactly the same problem some days ago.
The strange thing was that it was only with one of the domains.. all other domains did not have the 554 error!

I deleted the account/domain, and remade it.. after this all was fine again!

If you are having the 554 problem with only one domain, try what I did, and it might fix it also

jazzgillum 10th March 2006 04:26

Quote:

If you are having the 554 problem with only one domain, try what I did, and it might fix it also
Hmmm... I haven't tried adding additional domains yet. I don't think it will matter, though, because I totally removed and reinstalled Postfix and ISPConfig trying to fix the problem, with the same result. But I'll try setting one or two of my other domains up tomorrow to see if the same thing happens.

Thanks for the tip!

till 10th March 2006 08:41

Quote:

Originally Posted by jazzgillum
Hi,

I'm stuggling to get ISPConfig up and running. I followed the Ubuntu Perfect Setup. When I send test emails to user accounts that I have set up, I quickly get a bounce message back. Here's the complaint in the return mail:

PERM_FAILURE: SMTP Error (state 9): 554 <test@mydomain.dom>: Relay access denied

I've searched this forum and found lots of similar problems, but mostly about SENDING mail rather than RECEIVING it. I've tried some of the solutions suggested in the similar topics, but nothing has worked, so its possible that I've messed things up worse.

Again, I can send emails, but not recieve. Any help would be appriciated!

Have you created a website "www.mydomain.dom" in ISPConfig? Has this site a co-domain "mydomain.dom" with empty host field?

If yes:

Is the domain "mydomain.dom" listed in /etc/postfix/local-host-names ?

If "mydomain.dom" is not a local domain on your server, you will have to enable SMTP server authentication in your email client. In outlook the option is named like "Server needs authentication".

jazzgillum 10th March 2006 15:27

Quote:

Originally Posted by till
Have you created a website "www.mydomain.dom" in ISPConfig? Has this site a co-domain "mydomain.dom" with empty host field?

Yes.

Quote:

Originally Posted by till
If yes:

Is the domain "mydomain.dom" listed in /etc/postfix/local-host-names ?

Yes, both mydomain.dom and www.mydomain.dom are listed.

Quote:

Originally Posted by till
If "mydomain.dom" is not a local domain on your server, you will have to enable SMTP server authentication in your email client. In outlook the option is named like "Server needs authentication".

What do you mean by "a local domain on your server? The DNS (I'm using my registrar's DNS service) points to my IP and I've set "mydomain.dom" up through ISPConfig. The website is running just fine. Does that mean "mydomian.dom" is "a local domain" on my server?

Anyway, I don't understand how a setting in an email client could effect wether or not mail gets delivered to an address. Client or no client, the mail never arrives in the users "mailbox"!

Thanks for your help. I'll go ahead and set up another domain (I adjusted the DNS entries last night; they should have propogated by now) to check out edge's theory.

jazzgillum 10th March 2006 15:54

Okay, I set up another domain. Same result. Web page works. Sending mail out works (I'm using mail2web.com to get into the account and send mail) but incoming mail is rejected.

falko 10th March 2006 18:53

What's the domain of the incoming mail?
What's in /etc/postfix/local-host-names?

jazzgillum 10th March 2006 19:15

Quote:

Originally Posted by falko
What's the domain of the incoming mail?

You mean the actual domain the mail is addressed to? Sure, what the heck.

My test email address in this case is:
rick@ricklynn.com

Quote:

Originally Posted by falko
What's in /etc/postfix/local-host-names?

Code:

###################################
#
# ISPConfig local-host-names Configuration File
#        Version 1.0
#
###################################
localhost
server.localdomain
localhost.server.localdomain
localhost.localdomain
www.smallmericles.com
www.ricklynn.com
www.nbmap.com
smallmericles.com
ricklynn.com
nbmap.com
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

Here's the mail.log entries for a recent attempt to send:

Code:

Mar 10 12:02:18 localhost postfix/smtpd[20146]: connect from wproxy.gmail.com[64.233.184.196]
Mar 10 12:02:19 localhost postfix/smtpd[20146]: NOQUEUE: reject: RCPT from wproxy.gmail.com[64.233.184.196]: 554 <rick@ricklynn.com>: Relay access denied; from=<jazzgillum@gmail.com> to=<rick@ricklynn.com> proto=ESMTP helo=<wproxy.gmail.com>
Mar 10 12:02:19 localhost postfix/smtpd[20146]: disconnect from wproxy.gmail.com[64.233.184.196]


falko 11th March 2006 11:10

I found out that mail.ricklynn.com is the mail server for ricklynn.com. Then I did this:

Code:

dig mail.ricklynn.com

; <<>> DiG 9.2.1 <<>> mail.ricklynn.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30276
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;mail.ricklynn.com.            IN      A

;; ANSWER SECTION:
mail.ricklynn.com.      3336    IN      CNAME  ricklynn.com.
ricklynn.com.          3321    IN      A      216.212.44.217

;; Query time: 2 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Sat Mar 11 11:08:32 2006
;; MSG SIZE  rcvd: 65

mail.ricklynn.com is a CNAME, not an A record.

On http://langfeldt.net/DNS-HOWTO/BIND-9/DNS-HOWTO-5.html, I found this:

Quote:

CNAME (Canonical NAME) is a way to give each machine several names. So www is an alias for ns. CNAME record usage is a bit controversial. But it's safe to follow the rule that a MX, CNAME or SOA record should never refer to a CNAME record, they should only refer to something with an A record
Please change it!

jazzgillum 13th March 2006 15:37

I've changed the DNS entries:

Code:

; <<>> DiG 9.3.1 <<>> mail.ricklynn.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47115
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;mail.ricklynn.com.            IN      A

;; ANSWER SECTION:
mail.ricklynn.com.      3070    IN      A      216.212.44.217

;; AUTHORITY SECTION:
ricklynn.com.          3070    IN      NS      ns3.secureserver.net.
ricklynn.com.          3070    IN      NS      ns4.secureserver.net.

;; ADDITIONAL SECTION:
ns3.secureserver.net.  170722  IN      A      64.202.165.10
ns4.secureserver.net.  170722  IN      A      68.178.211.105

;; Query time: 111 msec
;; SERVER: 216.212.0.10#53(216.212.0.10)
;; WHEN: Mon Mar 13 08:26:47 2006
;; MSG SIZE  rcvd: 135

...but I still get the same results.

I'm also testing smallmericles.com. I set up the DNS differently, without a "mail" subdomain:

Code:

; <<>> DiG 9.3.1 <<>> smallmericles.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 14950
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;smallmericles.com.            IN      A

;; ANSWER SECTION:
smallmericles.com.      3360    IN      A      216.212.44.217

;; AUTHORITY SECTION:
smallmericles.com.      3360    IN      NS      NS3.SECURESERVER.NET.
smallmericles.com.      3360    IN      NS      NS4.SECURESERVER.NET.

;; ADDITIONAL SECTION:
NS3.SECURESERVER.NET.  170584  IN      A      64.202.165.10
NS4.SECURESERVER.NET.  170584  IN      A      68.178.211.105

;; Query time: 167 msec
;; SERVER: 216.212.0.10#53(216.212.0.10)
;; WHEN: Mon Mar 13 08:29:04 2006
;; MSG SIZE  rcvd: 135

...but it still behaves the same way, too.


All times are GMT +2. The time now is 14:08.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.