HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=33)
-   -   ISPC3: spamfilter_policy-problem with php-mail (http://www.howtoforge.com/forums/showthread.php?t=30037)

Antennipasi 6th January 2009 11:47

ISPC3: spamfilter_policy-problem with php-mail
 
yesterday i had first major problem with ISPC3.
i am taking it to production in steps, moving our own domains to it from Plesk. yesterday i moved one wich had forum in it. forum send mails with php-mail function to thread subscribes, and because forum is finnish language, message headers contain local characters.

problem was that those messages did not go thru ISPConfig to mailboxes in other domains allready moved to ISPC3 because they gor blocked by Amavisd&postfix with message:

Code:

amavis[2023]: (02023-08) Blocked BAD-HEADER ....snip...
postfix/smtp[17449]: ..snip.. (250 2.6.0 Ok, discarded, id=16826-01 - BAD_HEADER: Non-encoded 8-bit data ..snip..

when searching for reason, i found out that ISPConfigs own greetings-messages got stuck too because same reason. but these got passed earlier. so my eyes missed changes somewhere.

i fixed this by changing all spamfilter_policy:bypass_header_checks to "Y" in database.
i dont think this is really bug, amavis is just following settings that is given to it, and php-mail is not coding headers righ. but this behavior could cause lot of problems if not known by admin.

otherwise, it seemed messages was blocked also when smamfilter was off for destination domain, and that is a bug. i try to verify this later.


All times are GMT +2. The time now is 20:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.