HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   NameVirtualHost *:80 (http://www.howtoforge.com/forums/showthread.php?t=29912)

lucasajackson 31st December 2008 20:53

NameVirtualHost *:80
 
Hello,
I am new to Hosting with linux and ISPConfig. I just installed ISPConfig on my server, and followed the instructions on ISPConfig's website exactly.

I got the server up and running, and I am able to log into ISPConfig. I created a new client and website in ISPConfig, and I uploaded Drupal to the web file via ftp, but now when I go to the site it just comes up with a 500 server error.

In fact I tried to go to phpmyadmin, and it also gave me a 500 server error.

So I went in and restarted the apache2 services and it gives me warnings.

Quote:

* Restarting web server apache2 Warning: SuexecUserGroup directive requires SUEXEC wrapper.
[Wed Dec 31 14:41:23 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting Warning: SuexecUserGroup directive requires SUEXEC wrapper.
[Wed Dec 31 14:41:24 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
Any ideas on how to fix this?
Thank you,
Lucas

lucasajackson 31st December 2008 20:54

Forgot
 
I guess I should have added that I am using Ubuntu 8.10
Thank you

falko 1st January 2009 11:34

What's in Vhosts_ispconfig.conf?
Did you install ISPConfig 2 or 3?

lucasajackson 1st January 2009 16:18

vhost
 
I'm not sure where to find the Vhosts_ispconfig.conf but the version I am using is 3.0.0.8.

Thank you

till 1st January 2009 16:42

Please post the error messages from the apache errot log. Did you install ISPConfigg exactly as described in the installation instructions which are in the ispconfig 3 tar.gz filr?

lucasajackson 1st January 2009 16:59

errors and instructions
 
I used the instructions posted on ISPConfig's website here http://www.ispconfig.org/docs/INSTALL_UBUNTU_8.04.txt

The Apache error log says:
Quote:

Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
Warning: SuexecUserGroup directive requires SUEXEC wrapper.
[Thu Jan 01 10:55:24 2009] [error] [client 60.172.222.17] script '/usr/local/isp
config/interface/web/proxyip.php' not found or unable to stat

graz 4th February 2009 21:46

I had that problem also after using the 8.04 guide for a 8.10 UB install, to install ISPConfig 3.

I ran, apt-get install apache2-suexec

And that sorted it :-)


All times are GMT +2. The time now is 05:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.