HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   RoundCube 0.2-stable available for ISPConfig 2 (http://www.howtoforge.com/forums/showthread.php?t=29904)

Hans 31st December 2008 13:51

RoundCube 0.2-stable available for ISPConfig 2
 
1 Attachment(s)
On 30-12-2008 RoundCube 0.2-stable has been released. Based on this latest stable version, i've built a new package for ISPConfig 2. It is also my last contribution to this community for this year.

RoundCube 0.2-stable can be downloaded here. Please read the available readme file for install instructions. The previous stable RoundCube version 0.1.1 is also still available.

Happy RoundCube and i wish you all a happy 2009! :)

pjo 3rd January 2009 22:18

Hi,

I try to install roundcube 0.2 on a ISPConfig installation (to which I moved another ISPConfig installation), and I always get

Installation instructions not found: /home/admispconfig/ispconfig/temp/e6e9aaba36448a363b872b7dc6b7348a/package.ins

This occurs in both ways, upload and URL. What am I doing wrong? Any ideas?

Thx pjo

till 5th January 2009 12:00

Do not unpack the .pkg file before you upload.

pjo 5th January 2009 12:08

Thanks for reply!

Till, I do not unpack the pkg before uploading (and and as I wrote direct URL gives the same error).

Could it have an impact, because during migration of data from server A to server B I copied the whole /home/admispconfig folder?

falko 6th January 2009 09:25

Did you use this URL? http://ispconfig.bb-hosting.org/down...0.2-stable.pkg

pjo 6th January 2009 10:00

Hi Falko,

yes I tried it with different ones. Since my last post I recognized that I cant update with any pkg, although it worked (with myphpadmin) at Server B before migration from Server A (according to that thread).

So something might have happend during migration...

Thanks pjo

till 6th January 2009 11:33

If you have verwritten anything in /home/admispconfig/ on the new server then it might not work anymore. These directories should not be overwritten with any files or content from the old server.

Please post the output of:

ls -la /home/admispconfig/ispconfig/

pjo 6th January 2009 11:42

yes I transfered /home/admispconfig/ to the new server...
Any ideas, how to repair?

here's the ls output:

root@xxxxxx:/home/admispconfig# ls -ltra ispconfig/
total 4760
drwxr-xr-x 4 admispconfig admispconfig 4096 2008-02-13 00:01 files
drwxrwx--- 2 admispconfig mysql 4096 2008-02-13 00:01 backup
drwxr-xr-x 4 admispconfig admispconfig 4096 2008-02-13 00:01 ..
-rwxr-xr-x 1 admispconfig admispconfig 203 2008-02-13 15:50 users
-rwxr-xr-x 1 admispconfig admispconfig 862 2008-02-13 15:50 sysconf.txt
drwxr-xr-x 18 admispconfig admispconfig 4096 2008-02-14 10:04 web
drwxr-xr-x 11 admispconfig admispconfig 4096 2008-02-18 12:41 tools
-rw-r--r-- 1 root root 255208 2008-07-23 11:28 ispconfig.log.23-07-08_11-28-47.tar.gz
drwxr-xr-x 10 admispconfig admispconfig 4096 2009-01-05 12:10 temp
-rw-r--r-- 1 admispconfig admispconfig 4552869 2009-01-05 23:59 ispconfig.log
-rw-r--r-- 1 admispconfig admispconfig 11 2281-03-18 11:04 adminmail.txt
drwxr-xr-x 6 admispconfig admispconfig 4096 2281-03-18 11:42 lib
drwxr-xr-x 8 admispconfig admispconfig 4096 2281-03-18 23:38 .
root@xxxxxx:/home/admispconfig#


And here:

root@xxxxxx:/home/admispconfig# ls -ltra ispconfig/temp/5ee21591a812370662de8c587d4439ca/
total 1532
-rw-r--r-- 1 admispconfig admispconfig 1553989 2009-01-05 12:03 roundcu.pkg
drwx------ 2 admispconfig admispconfig 4096 2009-01-05 12:03 .
drwxr-xr-x 10 admispconfig admispconfig 4096 2009-01-05 12:10 ..
root@xxxxxx:/home/admispconfig#

till 6th January 2009 11:44

Download the latest ispconfig 2.2.x version and run the setup script to update your server, this should repair the contents of these folders as well.

pjo 6th January 2009 12:25

I updated with 2.2.29 and now it works!

Let me just shortly remark, that now after updating I have to use https to connect to my :81 ISPconfig, before I had it unencrypted, but this is also ok, so it forces me to more security :)

At this time let me say thanks to you for your great support and howtos and of course for developing ISPConfig in such a perfect way. I use this software now for nearly two years in a production environment and it never disappointed me!

Keep on doing the great work! If 3.0 is stable and the update/migration procedure will be not too strange, I'm sure I will do the same good experiences as I did in 2.x.

Regards, pjo


All times are GMT +2. The time now is 20:39.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.