HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Suse 9.3 And ModReWrite (http://www.howtoforge.com/forums/showthread.php?t=299)

marketingmaven 17th August 2005 01:13

Suse 9.3 And ModReWrite
 
Hi everyone,

I am new the the Linux environment, but I have installed ISPConfig, and it has made my life a lot easier with operating my new Linux Box.

I am installing WordPress sites on the box, and one of the options I need is to enable Mod ReWrite.

I have Apache and everything else installed right as per the Suse 9.3 install faq on the ISPConfig site, but I am not sure how to enable it. Do I enable it on the server in httpd.conf or do I do it in ISPConfig for each site with the Apache Directives option (which I dont know how to use either)?

Anyway, everytime I try to invoke anything to do with Mod ReWrite with WordPress, the WordPress site no longer works until I delete .htaccess. Please help. I really am not sure what to do, or how to do it. Thanks in advance.

falko 17th August 2005 13:43

From the howto:

Quote:

Edit /etc/sysconfig/apache2 and add rewrite to the APACHE_MODULES line:

APACHE_MODULES="access actions alias auth [...] setenvif ssl suexec userdir php4 php5 rewrite"

[...]

Then run

SuSEconfig
/etc/init.d/apache2 start
Then mod_rewrite is enabled.
You can then define rewrite conditions/rules in an .htaccess file, in the Apache Directives field in ISPConfig or by using the forward mechanism for Co-Domains (forwarding uses rewrite rules).

thevinster 17th August 2005 16:09

Similar problem on Wikka
 
I'm trying to install Wikka, and the .htaccess file reads:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.*/[^\./]*[^/])$ $1/
RewriteRule ^(.*)$ wikka.php?wakka=$1 [QSA,L]
</IfModule>


This keeps giving me a 403 error. It looks like a common problem, along with the people trying to set up Drupal.

Any suggestions?

falko 17th August 2005 16:33

Quote:

Originally Posted by thevinster
I'm trying to install Wikka, and the .htaccess file reads:

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.*/[^\./]*[^/])$ $1/
RewriteRule ^(.*)$ wikka.php?wakka=$1 [QSA,L]
</IfModule>


This keeps giving me a 403 error. It looks like a common problem, along with the people trying to set up Drupal.

Any suggestions?

Have a look at this thread: http://www.howtoforge.com/forums/showthread.php?t=38

marketingmaven 17th August 2005 16:39

Quote:

Originally Posted by falko
From the howto:



Then mod_rewrite is enabled.
You can then define rewrite conditions/rules in an .htaccess file, in the Apache Directives field in ISPConfig or by using the forward mechanism for Co-Domains (forwarding uses rewrite rules).

Thanks Falko. I guess I did that when setting up ISPConfig, just didnt know how to activate it. So let me see if I understand this. I dont actually upload a .htaccess file to the directory I need it in, I just set the define the rewrite rules in a .htacces file and put that file in the Apache Directives Field? Thanks in advance. :)

Oh, I need the .htaccess in a subfolder of the main site it seems. Do I still put the .htaccess file in the Apache Directives Field? When I upload the .htaccess file directly to the subfolder, the site fails. When I delete it, everything is fine again. Thanks.

thevinster 17th August 2005 18:05

Quote:

Originally Posted by falko


Falko,

That is the thread I was referring to in my post. I still don't completely understand how to modify the .htaccess system for these scripts. I am currently having trouble with Helpcenterlive as well.

The .htaccess file reads:

php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728


Only if I delete the .htaccess file is it working.

till 17th August 2005 18:07

Quote:

Originally Posted by thevinster
Falko,

That is the thread I was referring to in my post. I still don't completely understand how to modify the .htaccess system for these scripts. I am currently having trouble with Helpcenterlive as well.

The .htaccess file reads:

php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728


Only if I delete the .htaccess file is it working.

Have you tried to put exactly this

Code:

php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728

in the apache directives field of the ISPConfig site?

thevinster 17th August 2005 18:16

Quote:

Originally Posted by till
Have you tried to put exactly this

Code:

php_value upload_max_filesize 128M
php_value post_max_size 128M
LimitRequestBody 134217728

in the apache directives field of the ISPConfig site?

Hi Till,

Yes I have. It works of course. But if I wanted to isolate those instructions to one particular directory, say /home/www/web150/web/seperate_directory, how would I do that?

falko 17th August 2005 18:36

Quote:

Originally Posted by thevinster
Hi Till,

Yes I have. It works of course. But if I wanted to isolate those instructions to one particular directory, say /home/www/web150/web/seperate_directory, how would I do that?

Like this:

Code:

<Location '/seperate_directory'>
  php_value upload_max_filesize 128M
  php_value post_max_size 128M
  LimitRequestBody 134217728
</Location>


thevinster 17th August 2005 18:55

Quote:

Originally Posted by falko
Like this:

Code:

<Location '/seperate_directory'>
  php_value upload_max_filesize 128M
  php_value post_max_size 128M
  LimitRequestBody 134217728
</Location>


Perfect!

Many thanks for this. ISPConfig is such an extremely useful piece of software, even if you're managing just one site on it.


All times are GMT +2. The time now is 14:55.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.