HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig lost control of DNS and other services (http://www.howtoforge.com/forums/showthread.php?t=29741)

tpw 24th December 2008 06:22

ISPConfig lost control of DNS and other services
 
Hi,

I wonder if someone could give me some help in this problem: somehow ISPConfig isn't controlling DNS records of my server anymore. My problem is that only the old domains that I have configured earlier are working, but now when I try to add a new one, the change that I have made in ISPConfig doesn't reflect at named.conf. I can see there only the old domains. The DNS test at OpenDNS.com gives me "xxx.xxxxxxxxx.net returned (NORECORDS)". Worse than that, it seems that I can't even turn off or restart ANY service from ISPConfig. All the web pages that I have configured earlier are working perfect, though.

I'm using Centos 4, and I haven't done any manual changes on the system. I've done the "perfect server install" and I've been maintaning the system with yum upgrade every now and then and I've updated ISPConfig to the latest stable version. The only major modification on the system is that I've added PHP 5.2 through a private repository with yum.

Thanks,

Juho

till 24th December 2008 10:42

I guess you installed a bind update in centos which breaks the dns setup. Please reconfigure bind as described in the perfect setup guide again and then make sure that the path to the bind config files under management > server > settings is correct.

tpw 24th December 2008 20:05

Thanks for your help. When I find a free moment I'll do it and then I'll write again.

Juho

tpw 25th December 2008 03:59

OK, you were right. The update of bind had broken the DNS setup.

I found another thread about this: http://www.howtoforge.com/forums/showthread.php?t=11207

I configured bind again as the perfect setup guide indicates, but also I had to change one line in /etc/named.conf:

Code:

pid-file "/var/named/chroot/var/run/named/named.pid";
directory "/var/named/chroot/var/named";

I also changed the server setting in ISPConfig from:

/home/admispconfig/ispconfig/web/multidoc/edit

to:

/var/named/chroot/var/named

It's working like a dream now. Thanks again.


Juho


All times are GMT +2. The time now is 01:56.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.