HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   Sendmail problem (http://www.howtoforge.com/forums/showthread.php?t=2973)

Nejko 8th March 2006 13:44

Sendmail problem
 
Hey

i finaly managed to get sendmail half-working :D It can send emails, but it can not accept them.. i have no idea what should be wrong. i forwarded all ports from 20-144. hoping for fast answer :)

cya, Nejko

falko 8th March 2006 20:50

What's in the mail log when an email is comaing in?

Nejko 8th March 2006 20:52

Mar 8 12:35:10 localhost sendmail[30617]: k28BZAhr030617: to=<nero-server@localhost.localdomain>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=33690, dsn=2.0.0, stat=Sent
Mar 8 13:20:52 localhost sendmail[31247]: k28CKq7e031247: from=nejc@nero-server.com, size=418, class=0, nrcpts=1, msgid=<1141820452.31245@localhost.localdomain>, relay=root@localhost
Mar 8 13:20:52 localhost sendmail[31250]: k28CKqrt031250: from=<nejc@nero-server.com>, size=581, class=0, nrcpts=1, msgid=<1141820452.31245@localhost.localdomain>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
Mar 8 13:20:52 localhost sendmail[31247]: k28CKq7e031247: to=nejc.zurej@siol.net, ctladdr=nejc@nero-server.com (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30418, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (k28CKqrt031250 Message accepted for delivery)
Mar 8 13:20:56 localhost sendmail[31252]: k28CKqrt031250: to=<nejc.zurej@siol.net>, delay=00:00:04, xdelay=00:00:04, mailer=esmtp, pri=120581, relay=mailhub.siol.net. [193.189.160.25], dsn=2.0.0, stat=Sent (Message received: 20060308122045.QPII17682.mailhub.sio...calhos t.localdomain)

that's some lines of the latest..

falko 8th March 2006 21:31

Looks ok. Please post the output of
Code:

netstat -tap

Nejko 8th March 2006 21:40

[root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:20000 *:* LISTEN 2455/perl
tcp 0 0 *:32769 *:* LISTEN 1830/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2271/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1812/portmap
tcp 0 0 *:10000 *:* LISTEN 3930/perl
tcp 0 0 192.168.2.101:domain *:* LISTEN 2767/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2767/named
tcp 0 0 *:ftp *:* LISTEN 2292/proftpd: (acce
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2129/cupsd
tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2111/mDNSResponder
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2767/named
tcp 0 0 localhost.localdomain:smtp *:* LISTEN 2309/sendmail: acce
tcp 0 0 *:http *:* LISTEN 2333/httpd
tcp 0 0 *:ssh *:* LISTEN 2177/sshd
tcp 0 0 *:https *:* LISTEN 2333/httpd
tcp 0 0 ::ffff:192.168.2.101:ssh ::ffff:192.168.2.100:2957 ESTABLISHED 4700/1
[root@localhost ~]#

falko 9th March 2006 10:32

There's no POP3 or IMAP daemon running! That's why you can't fetch your emails with an email client like Outlook or Thunderbird. Please start POP3.

Nejko 9th March 2006 15:07

[root@localhost ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:20000 *:* LISTEN 2455/perl
tcp 0 0 *:32769 *:* LISTEN 1830/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2271/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1812/portmap
tcp 0 0 *:10000 *:* LISTEN 3930/perl
tcp 0 0 192.168.2.101:domain *:* LISTEN 2767/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2767/named
tcp 0 0 *:ftp *:* LISTEN 2292/proftpd: (acce
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2129/cupsd
tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2111/mDNSResponder
tcp 0 0 localhost.localdomain:smtp *:* LISTEN 13435/sendmail: acc
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2767/named
tcp 0 0 192.168.2.101:10000 192.168.2.100:4911 TIME_WAIT -
tcp 0 0 192.168.2.101:10000 192.168.2.100:4912 ESTABLISHED 14631/perl
tcp 0 0 192.168.2.101:10000 192.168.2.100:4913 ESTABLISHED 14632/perl
tcp 0 0 *:imaps *:* LISTEN 13226/dovecot
tcp 0 0 *:pop3s *:* LISTEN 13226/dovecot
tcp 0 0 *:pop3 *:* LISTEN 13226/dovecot
tcp 0 0 *:imap *:* LISTEN 13226/dovecot
tcp 0 0 *:http *:* LISTEN 2333/httpd
tcp 0 0 *:ssh *:* LISTEN 2177/sshd
tcp 0 0 *:https *:* LISTEN 2333/httpd
tcp 0 296 ::ffff:192.168.2.101:ssh ::ffff:192.168.2.100:4923 ESTABLISHED 14636/1
[root@localhost ~]#


still no mails to inside..

falko 9th March 2006 21:04

You must make Sendmail deliver emails to Maildir instead of mbox.

Nejko 9th March 2006 21:19

Can u please explain a bit? ;)

ok, got mbow. so i change it to what?
/////////////////////////////////////////////////////7

i did:
Mail file in home directory: Mail file in home directory

and in dovecot:
Mail file location: Inbox and folders in ~/Maildir

(i'm using webmin)

But still no mails from outside :S

falko 9th March 2006 22:32

Do you have a screenshot of the webmin settings?


All times are GMT +2. The time now is 19:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.