HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   cannot mkfs.xfs /dev/sda2 on Ubuntu Server 8.10 (http://www.howtoforge.com/forums/showthread.php?t=29251)

jonniefive79 5th December 2008 04:09

cannot mkfs.xfs /dev/sda2 on Ubuntu Server 8.10
 
I have Ubuntu server 8.10 [64-bit] on a RAID 10 Array (amlost) I followed the guide to partioning my HDDs found here and all was well until I tried to follow the guide for Minimal Ubuntu Server Install I get
Code:

mkfs.xfs: cannot open /dev/sda2: Device or resource busy
when I enter
Code:

mkfs.xfs /dev/sda2
I have partitioned [4] 1TB drives just like the guide says using cfdisk:

-sda1 50MB boot; sda2 999000MB Linux raid autodetect; sda3 1000MB swap
-sdb1 999000MB Linux raid autodetect; sdb2 1000MB swap
-sdc1 999000MB Linux raid autodetect; sdc2 1000MB swap
-sdd1 999000MB Linux raid autodetect; sdd2 1000MB swap

Any ideas what I need to do?

sjau 5th December 2008 09:47

as it is a raid now you can't access it by /dev/sda2... you need to address the according mapper... very likely it will be /dev/md0.... but you'll have to verify that.

jonniefive79 5th December 2008 14:13

OK I see where there's a problem now.

Here's what I did

Code:

mkfs.xfs /dev/md0
ln /dev/md0 /dev/sde

The guide said to do this, what do I do now. Sorry I'm a noob.

Thanks,
-Jon


All times are GMT +2. The time now is 00:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.