HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Samba PDC - Access Denied (http://www.howtoforge.com/forums/showthread.php?t=2878)

HoUsECAt 4th March 2006 17:34

Samba PDC - Access Denied
 
I succesfully managed to get trough the great samba as PDC on ubuntu tutorial - great work!

Only i have a problem adding my windows xp pro machine. When i want to join the domain, i have to enter login and username.. I login with my Administrator account to add the machine.

Only i get the message : Access Denied ...

the password for Administrator equals the one for root, isn't ?

Anyone?

HoUsECAt 6th March 2006 12:00

Got a little further now

step 1
---
I believe it has something to do with rights ... because when i enter a wrong password it says : wrong username or password

step 2
---
commented the line
Code:

invalid users = root
-----

now currently in the logfile i find:

Code:

[2006/03/06 15:12:55, 3] rpc_server/srv_samr_nt.c:_samr_create_user(2330)
  _samr_create_user: winbind_create_user(clientname$) failed

any ideas?

till 6th March 2006 20:18

When you want to join a domain with winXP, you will have to enter the user username (not root) in the first step of the whizard and then for the second step you will have to use the Administrator login.

HoUsECAt 6th March 2006 23:03

Thanks for your reply, i first didn't used the wizard, now it did... but it says:

Cannot find user when i enter the Administrator + password in the second step...

till 7th March 2006 08:04

What is the content of /etc/samba/smbusers?

Please post the out put of the command:

smbclient -L localhost -U%

when you are logged in as root user (not sudo!).

HoUsECAt 7th March 2006 08:54

in my /etc/samba/smbusers is only 1 line:

Code:

root = Administrator
output of smbclient

Code:

root@adam:~# smbclient -L localhost -U%
added interface ip=172.16.*.* bcast=172.16.127.255 nmask=255.255.128.0
Client started (version 3.0.14a-Ubuntu).
resolve_wins: Attempting wins lookup for name localhost<0x20>
name_resolve_bcast: Attempting broadcast lookup for name localhost<0x20>
resolve_hosts: Attempting host lookup for name localhost<0x20>
Connecting to 127.0.0.1 at port 445
Domain=[DOMAIN] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
dos_clean_name []

        Sharename      Type      Comment
        ---------      ----      -------
        netlogon        Disk      Network Logon Service
        print$          Disk      Printer Drivers
        IPC$            IPC      IPC Service (adam server (Samba, Ubuntu))
        ADMIN$          IPC      IPC Service (adam server (Samba, Ubuntu))
Connecting to 127.0.0.1 at port 139
Domain=[DOMAIN] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
dos_clean_name []

        Server              Comment
        ---------            -------
        ADAM                adam server (Samba, Ubuntu)

        Workgroup            Master
        ---------            -------
        DOMAIN            ADAM

any ideas?

till 7th March 2006 22:23

Did you get any errors in your samab logfiles in /var/log/samba ?

Are you sure you executed this command during setup?

smbpasswd -a root

HoUsECAt 7th March 2006 22:46

yeah i'm sure i enterend that command during setup, just did it again... same error.

In the logfile of the client (log.clientname) i see the following... please let me know if you need to see more of the logfiles

Code:

[2006/03/07 22:46:31, 3] smbd/sec_ctx.c:pop_sec_ctx(386)
  pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
[2006/03/07 22:46:31, 3] rpc_server/srv_samr_nt.c:_samr_create_user(2330)
  _samr_create_user: winbind_create_user(clientname$) failed


HoUsECAt 8th March 2006 14:26

solved!!

i copied my smb.conf to smb.old.conf ... and copied the smb.conf from the tutorial... STUPID OF ME!! there should be a contradiction in the both.. for the fans.. i got both versions..

PlanBForOpenOffice 25th November 2007 21:59

I had similar issues, here is what I found out

The following line (uncommented) did give me the "Access denied" message, when I tried to join a new machine to the network and used root or Administrator to log on.
Code:

; invalid users = root
This line missing from my configuration did prevent me from using the "Administrator" alias for root.
Code:

username map = /etc/samba/smbusers
Learned some more

K<o>


All times are GMT +2. The time now is 13:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.