HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   FTPS settings in /etc/proftpd_ispconfig.conf get overwritten (http://www.howtoforge.com/forums/showthread.php?t=28748)

jahn 17th November 2008 13:12

FTPS settings in /etc/proftpd_ispconfig.conf get overwritten
 
Hello I am a user of ISPConfig,
currently I am using the SVN dev branch version and it works fine.

I wanted to setup FTPS in proftpd like described in this Post: http://www.howtoforge.com/forums/sho...76&postcount=7
and it works fine, but after some time the /etc/proftpd_ispconfig.conf gets overwritten and the TLS Settings are gone -

Is there a way I can prevent this or a way I can make ISPConfig aware of these settings?

Thanks in advance.
jahn

btw: i am using ispconfig on ubuntu 8.04 if that matters..

_X_ 17th November 2008 14:17

you can try to add

<VirtualHost your_ip>
TLSEngine on
TLSRSACertificateFile /etc/ssl/certs/proftpd.cert.pem
TLSRSACertificateKeyFile /etc/ssl/certs/proftpd.key.pem
</VirtualHost>

to main proftpd conf file:

/etc/proftpd/proftpd.conf

after include /etc/proftpd_ispconfig.conf line

jahn 17th November 2008 16:21

Solution
 
I found the solution to my problem.
There is a file called /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master, I had to edit.
Its the template ISPConfig uses to rewrite the /etc/proftpd_ispconfig.conf.
This ist how my /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master looks now:
Code:

###################################
#
# ISPConfig proftpd Configuration File
#        Version 1.0
#
###################################

DefaultAddress 127.0.0.1

<!-- BEGIN DYNAMIC BLOCK: vhost -->
<VirtualHost {IP}>
        DefaultRoot            ~
        AllowOverwrite          on
        Umask                  002
        TLSEngine on
        #TLSRequired on
        TLSRSACertificateFile      /etc/proftpd/cert/proftpd.cert.pem
        TLSRSACertificateKeyFile    /etc/proftpd/cert/proftpd.key.pem
        {ANON_FTP}
</VirtualHost>
<!-- END DYNAMIC BLOCK: vhost -->


jahn 17th November 2008 21:42

! little off topic !
This has nothing to do with FTPS, but its also about manual settings in ISPControl generated files, the vhosts.

For example: If you automatically want to add Apache Directives to every created site you can edit this template:
/root/ispconfig/isp/conf/vhost.conf.master

You could add an php_admin_value directive or every other directive you want....
Code:

...
php_admin_value open_basedir {HTTPD_ROOT}/{WEB}/
...


till 17th November 2008 23:26

Dont edit the files in /root/ispconfig/isp/conf/, instead copy the file to /root/ispconfig/isp/conf/customized_templates/ and edit this copy. This prevents that ispconfig removes your changes when you update ispconfig the next time.


All times are GMT +2. The time now is 10:50.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.