HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   configuration problem (http://www.howtoforge.com/forums/showthread.php?t=28728)

ALonon 16th November 2008 12:24

configuration problem
 
hello
My os is centos 5.2
i can not add my domain to apache
httpd.conf
Kod:

Code:

NameVirtualHost 94.75.214.13:80
<VirtualHost 94.75.214.13:80>
    ServerAdmin webmaster@xx.net
    DocumentRoot /home/xx/www
    ServerNamexx.net
    ServerAlias www.xx.net
    ErrorLog /home/xx/logs/uldl.net-error_log
    CustomLog /home/uldl/logs/xx.netaccess_log common
</VirtualHost>

where is the problem ?
when i type host xx.net

host xx.net ;; connection timed out; no servers could be reached
thanks

topdog 17th November 2008 09:13

Either firewall is blocking port 80 or port 80 is not listening to that address

ALonon 17th November 2008 09:15

in httpd.conf

Code:

Listen 80
isn't it correct ?

topdog 17th November 2008 09:22

That is correct but check using
Code:

netstat -ntlp
and
Code:

iptables-save

ALonon 17th November 2008 18:45

for netstat -ntlp
Code:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address              Foreign Address            Stat                            e      PID/Program name
tcp        0      0 0.0.0.0:902                0.0.0.0:*                  LIST                            EN      1992/rpc.statd
tcp        0      0 0.0.0.0:111                0.0.0.0:*                  LIST                            EN      1955/portmap
tcp        0      0 127.0.0.1:53                0.0.0.0:*                  LIST                            EN      12419/named
tcp        0      0 127.0.0.1:631              0.0.0.0:*                  LIST                            EN      2258/cupsd
tcp        0      0 127.0.0.1:953              0.0.0.0:*                  LIST                            EN      12419/named
tcp        0      0 127.0.0.1:25                0.0.0.0:*                  LIST                            EN      2282/sendmail: acce
tcp        0      0 :::80                      :::*                        LIST                            EN      10476/httpd
tcp        0      0 ::1:53                      :::*                        LIST                            EN      12419/named
tcp        0      0 :::22                      :::*                        LIST                            EN      2243/sshd
tcp        0      0 ::1:953                    :::*                        LIST                            EN      12419/named

there is no output for iptables-save

falko 18th November 2008 14:21

Quote:

Originally Posted by ALonon (Post 155286)
Code:

NameVirtualHost 94.75.214.13:80
<VirtualHost 94.75.214.13:80>
    ServerAdmin webmaster@xx.net
    DocumentRoot /home/xx/www
    ServerNamexx.net
    ServerAlias www.xx.net
    ErrorLog /home/xx/logs/uldl.net-error_log
    CustomLog /home/uldl/logs/xx.netaccess_log common
</VirtualHost>


It must be
Code:

ServerName xx.net
(with a space).


All times are GMT +2. The time now is 11:29.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.