HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   E-mail domain not working with ISPConfig (http://www.howtoforge.com/forums/showthread.php?t=28646)

fdsg72-lux 12th November 2008 17:54

E-mail domain not working with ISPConfig
 
2 Attachment(s)
Hi there,

Background:
I completed the following How To's to setup fresh install of Ubuntu 8.10 with ISPConfig and RoundCube WebMail:
=> Ubuntu 8.10: http://www.howtoforge.com/perfect-server-ubuntu-8.10
=> ISPConfig post-install setup: http://www.howtoforge.com/ispconfig-2.x-first-steps-p3
=> RoundCube Webmail: http://www.howtoforge.com/roundcube_webmail_ispconfig
Issue:
The e-mail domain 'oralab.com' listed in ISPConfig tab when creating users (see screen captures for details) is not working when sending e-mail to user@oralab.com nor when logging into RoundCube with user@oralab.com. Sending e-mail and logging in does work when using the full domain name of the website webmail.oralab.com e.g. user@webmail.oralab.com works.

Here are the entries from my /etc/postfix/virtusertable file:
###################################
#
# ISPConfig virtusertable Configuration File
# Version 1.0
#
###################################
fdadmin@webmail.oralab.com web4_fdadmin
web4_fdadmin@webmail.oralab.com web4_fdadmin
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
I do not see aliases for oralab.com, only for webmail.oralab.com, is this expected? Is there some other config/file where oralab.com is setup as an alias for webmail.oralab.com that I should verify/confirm?

Help:
Please let me know where to make the necessary change to allow e-mail to be sent to user@oralab.com and allow users to login with user@oralab.com?

Thanks,
Faan

_X_ 12th November 2008 19:26

You need to define at Basis:
Hostname: www
Domain: oralab.com

then go to Co-Domains and add:
1)
Hostname: < empty
Domain: oralab.com
2)
Hostname: mail
Domain: oralab.com
Forward: http(s)://www.oralab.com/roudcube_path

dissable Create DNS and Create DNS MX

this way your site will be accessable at www.oralab.com and oralab.com (without www.) and webmail (roundcube) can be acccessed at mail.oralab.com since it exists in DNS records

fdsg72-lux 13th November 2008 08:09

Thank you for the suggested solution but I already have oralab.com as a co-domain of www.oralab.com configured exactly the way you described but am not able to actually send e-mail to user@oralab.com, only to user@webmail.oralab.com.

I tried sending e-mail from one oralab.com e-mail account to another oralab.com e-mail account and even this fails.

Is there some config file that I can verify the contents of to confirm that oralab.com is correctly setup as an alias domain for webmail.oralab.com as the /etc/postfix/virtusertable file do not have any such mappings?

Thanks,
Faan

_X_ 13th November 2008 13:37

did you disabled Create DNS and Create DNS MX for webmail.oralab.com?

btw MX record for oralab.com is mail.oralab.com. check it here:
http://www.mxtoolbox.com

fdsg72-lux 14th November 2008 01:31

Yes, these 2 checkboxes are disabled/cleared for webmail.oralab.com. I also checked my bind zone files and see that oralab.com, mail.oralab.com, webmail.oralab.com, www.oralab.com all point to my host of 172.16.0.67, so I do not believe there is an issue with DNS resolution.

Is there something in postfix that I can verify to find out why e-mail to user@oralab.com fails but user@webmial.oralab.com works?

Thanks,
Faan

_X_ 14th November 2008 01:53

as far as I can see there are few problems:
1) ping www.oralab.com and mail.oralab.com: 64.106.152.211
2) ping webmail.oralab.com: request failed.

are you using godaddy ?

_X_ 14th November 2008 03:57

all mail errors can be tracked in:
/var/log/mail.log


All times are GMT +2. The time now is 16:11.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.