HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   RoundCube Webmail "AllowOverride Options" Location (http://www.howtoforge.com/forums/showthread.php?t=28644)

fdsg72-lux 12th November 2008 16:25

RoundCube Webmail "AllowOverride Options" Location
 
Hi there,

Background:
I completed the following How To's to setup fresh install of Ubuntu 8.10 with ISPConfig and RoundCube WebMail:

=> Ubuntu 8.10: http://www.howtoforge.com/perfect-server-ubuntu-8.10
=> ISPConfig post-install setup: http://www.howtoforge.com/ispconfig-2.x-first-steps-p3
=> RoundCube Webmail: http://www.howtoforge.com/roundcube_webmail_ispconfig

Issue:
With RoundCube Webmail I am hitting the issue with the PHP options in the .htaccess file giving "500 Internal Server Error". After researching this issue I accordingly modified the file /etc/apache2/vhosts/Vhosts_ispconfig.conf for the appropriate <VirtualHost ...> section for my website by updating the following line inside the section:

<IfModule mod_python.c>
<Directory /var/www/web4/web>":
...
</Directory>
</IfModule>

from

=> AllowOverride Indexes AuthConfig Limit FileInfo

to

=> AllowOverride Options Indexes AuthConfig Limit FileInfo

and then restart apache2 which resolves the issue momentarily.

The problem is that if I make any change via ISPConfig e.g. update a setting of the website, then the file /etc/apache2/vhosts/Vhosts_ispconfig.conf is regenerated and I loose my edit which then again breaks the RoundCube Webmail functionality.

Question:
Where is the correct location to make the change for my website so it will not get overwritten when I make changes via ISPConfig? I also tried adding the following all by itself within the <VirtualHost ...> section, both as the first and last entry within this section:

<Directory /var/www/web4/web>
AllowOverride Options
</Directory>

but it does not make any difference, only when I update existing definitions of the like

<IfModule ...>
<Directory /var/www/web4/web>
...
</Directory>
</IfModule>

does the change work.

Help:
Please tell me what exact change I have to make exactly where to resolve this issue?

Thanks,
Faan

till 13th November 2008 12:25

Quote:

Where is the correct location to make the change for my website so it will not get overwritten when I make changes via ISPConfig?
You must add your changed code to the apache directives field in the website settings. Never edit the file Vhosts_ispconfig.conf manually!


All times are GMT +2. The time now is 17:15.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.