HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=15)
-   -   Web-FTP Login, sits and then logs out of ISPConfig w/ errors (http://www.howtoforge.com/forums/showthread.php?t=2854)

teleriddler 3rd March 2006 04:28

Web-FTP Login, sits and then logs out of ISPConfig w/ errors
 
OK,

So I am only experiencing this on one of my domains. The admin account tries to login via the Web-FTP application and the 3 logos start to show up then the page hangs and spits out a bunch of error messages that are immediately erased and I am sent to the login page for ISPConfig. This is strange behavior and I cannot find a log file anywhere on the system that displays the errors I am experiencing. How do I know, I have done a "tail -f" on each log file I can find and replicate the error and nothing new shows up an any of the logs I have tailed. This only happens for 1 site as the 5 other sites I host can login completely fine to the Web-FTP application in ISPConfig.

Any ideas???


TeleRiddler

falko 3rd March 2006 16:50

Quote:

Originally Posted by teleriddler
OK,

So I am only experiencing this on one of my domains. The admin account tries to login via the Web-FTP application and the 3 logos start to show up then the page hangs and spits out a bunch of error messages that are immediately erased and I am sent to the login page for ISPConfig.

Can you try to hit the browser's stop button when you see these error messages and post them here? Or can you remember what these messages are saying?

teleriddler 3rd March 2006 16:57

Error Messages
 
Falko,

The error message go by too fast. I have no way to capture them but I will keep trying. I have checked all the log files and cannot find anything that looks close to what I see for a glimpse.


TeleRiddler

teleriddler 3rd March 2006 17:06

Good to see "Print Screen" still has a use
 
1 Attachment(s)
OK,

So after trying to time my browser to stop at the error page, it hit me. The print screen command worked fantastically.

I have attached a JPEG of the errors to this message. I will type them out in a bit.


TeleRiddler

falko 3rd March 2006 17:37

The guy in this thread had the same problem: http://www.howtoforge.com/forums/showthread.php?t=2557
Maybe his solution works for you?

teleriddler 3rd March 2006 19:31

PHP code change
 
I tried that solution and no dice.

Here is how the code of ispconfig_db_mysql.lib.php looks after the mod.


Code:

function connect()
                {
                        if($this->linkId == 0)
                        {
                                $this->linkId = mysql_connect($this->dbHost, $this->dbUser, $this->dbPass);
                                mysql_query("SET character_set_client = 'latin1'");
                                mysql_query("SET character_set_results = latin1");
                                mysql_query("SET character_set_connection = utf8");
                                if(!$this->linkId)
                                {
                                        $this->updateError('DB::connect()<br />mysql_connect');
                                        return false;
                                }
                        }
                        return true;
                }

I still get the same error when I login. Since this only happens with 1 domain I don't see how changing the whole code base would resolve this. The other domains login just fine and unfortunately this is the only user who needs this functionality, oh well.

teleriddler 3rd March 2006 19:37

Ftp
 
Just to let you know I have a Fedora Core 4 installation using the Perfect Setup. Things have been running fine for about 2 months now. I just grabbed smartFTP and can verify that I can login successfully with the faulty domain/account in question.

So if I can get into FTP just fine from a client, I wonder what would be making the web based version mess up? I will start running extensive debugging.

TeleRiddler


All times are GMT +2. The time now is 10:03.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.