HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   Mutt/Postfix: User unknown in virtual alias table (http://www.howtoforge.com/forums/showthread.php?t=27692)

somae 10th October 2008 07:47

Mutt/Postfix: User unknown in virtual alias table
 
I'm getting this message in /var/log/mail.log when trying to send email with mutt: "User unknown in virtual alias table" (The mail bounces). We've got Mutt 1.5.13 and Debian Linux 2.6.18-6-686 (i686).

I have no problem sending mail with icedove (thunderbird).

I'm new to postfix (and mutt) and don't understand how to configure the difference between our computer's domain and the domain of the dsl server.

Help appreciated.

falko 11th October 2008 18:41

Did you create an email account on the server? If so, how?

somae 13th October 2008 08:47

Quote:

Originally Posted by falko (Post 149636)
Did you create an email account on the server? If so, how?

Do you mean - did I create an email account on postfix? We created one in icedove and in evolution which both function ok.

I did create an account using
Code:

sudo useradd -m -s /bin/bash
although we already had a user set up previously.

When I try to send mail to the user

I get:
Quote:

telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 TTIL.soma.org ESMTP Postfix (Debian/GNU)
ehlo localhost
250-TTIL.soma.org
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
mail from: root@localhost
250 2.1.0 Ok
rcpt to: fmaster
550 5.1.1 <fmaster>: Recipient address rejected: User unknown in virtual alias table

falko 14th October 2008 17:50

Try to set up an email account as follows: http://www.howtoforge.com/forums/showthread.php?t=2

somae 14th October 2008 20:40

Quote:

Originally Posted by falko (Post 149918)
Try to set up an email account as follows: http://www.howtoforge.com/forums/showthread.php?t=2

Thanks. I no longer get the message about the user not being in the virtual alias table. But there still seems to be a problem.

When I try sending mail thru "telnet localhost 25" etc., everything seems to go ok but the mail doesn't show up when I type "mail" for the user. It is showing up at /root/Maildir/new.

Also, there is no /Maildir directory for some users and no /home/user directory for others.

Update: the mail.log gives this error message: "warning: maildir access problem for UID/GID=1002/100: create maildir file home/sysuser/Maildir/tmp/122401558"

falko 15th October 2008 14:19

What's the output of
Code:

ls -la /home/sysuser
? Seems to be a permissions problem.

somae 16th October 2008 07:06

Quote:

Originally Posted by falko (Post 150094)
What's the output of
Code:

ls -la /home/sysuser
? Seems to be a permissions problem.

There isn't a directory named "sysuser" on the system even though I thought I created it using
Code:

sudo useradd -m -s /bin/bash
Quote:

7# ls -la /home/sysuser
ls: /home/sysuser: No such file or directory
I just tried it again and got:
Quote:

# sudo useradd -m -s /bin/bash sysuser
useradd: user sysuser exists

falko 17th October 2008 13:35

What's sysuser's home directory? You can find it in /etc/passwd.

somae 18th October 2008 07:33

Quote:

Originally Posted by falko (Post 150438)
What's sysuser's home directory? You can find it in /etc/passwd.

sysuser:x:1002:100::/home/sysuser:/bin/sh

falko 19th October 2008 13:20

Try this:
Code:

mkdir /home/sysuser
chown sysuser:users /home/sysuser



All times are GMT +2. The time now is 19:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.