HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   BIND Setup HELP Please! (http://www.howtoforge.com/forums/showthread.php?t=27187)

erentil 27th September 2008 04:57

BIND Setup HELP Please!
 
Hello everyone,
Ive been going crazy all day trying to figure out this Bind business. After reading forums for 7 hours and troubleshooting, i finally have it starting up error free (at least i believe so).
Quote:

Sep 26 22:44:36 webserver named[12922]: starting BIND 9.4.2-P1 -u bind -t /var/lib/named
Sep 26 22:44:36 webserver named[12922]: found 1 CPU, using 1 worker thread
Sep 26 22:44:36 webserver named[12922]: loading configuration from '/etc/bind/named.conf'
Sep 26 22:44:36 webserver named[12922]: listening on IPv4 interface lo, 127.0.0.1#53
Sep 26 22:44:36 webserver named[12922]: listening on IPv4 interface eth0:avahi, 169.254.8.168#53
Sep 26 22:44:36 webserver named[12922]: listening on IPv4 interface eth1, 192.168.1.148#53
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 127.IN-ADDR.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 254.169.IN-ADDR.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0. 0.0.0.0.0.0.0.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: D.F.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 8.E.F.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: 9.E.F.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: A.E.F.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: automatic empty zone: B.E.F.IP6.ARPA
Sep 26 22:44:36 webserver named[12922]: command channel listening on 127.0.0.1#953
Sep 26 22:44:36 webserver named[12922]: command channel listening on ::1#953
Sep 26 22:44:36 webserver named[12922]: zone 0.0.127.in-addr.arpa/IN: loaded serial 4
Sep 26 22:44:36 webserver named[12922]: zone mydomain.com/IN: loaded serial 2008092604
Sep 26 22:44:36 webserver named[12922]: running
i tried a dig and a host query thing and this is what i recieve:

host mydomain.com
mydomain.com has address 192.168.1.151


and my dig results are

Quote:

dig mydomain.com

; <<>> DiG 9.4.2-P1 <<>> mydomain.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 43444
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

;; QUESTION SECTION:
;mydomain.com. IN A

;; ANSWER SECTION:
mydomain.com. 86400 IN A 192.168.1.151

;; AUTHORITY SECTION:
mydomain.com. 86400 IN NS WEBSERVER.mydomain.com.

;; ADDITIONAL SECTION:
WEBSERVER.mydomain.com. 86400 IN A 192.168.1.148

;; Query time: 0 msec
;; SERVER: 192.168.1.148#53(192.168.1.148)
;; WHEN: Fri Sep 26 22:44:19 2008
;; MSG SIZE rcvd: 87
i still cant connect to any of my domain pages (eg mark.mydomain.com)

any help would be appreciated, i am stumped

marpada 27th September 2008 05:17

What kind of DNS server is: internal or external(internet)?. In later case you shoud put the public IP, not the internal 192.168.x.x one
________
Religion board
________
LovelyWendie99

erentil 27th September 2008 05:27

currently hosting internally

falko 28th September 2008 13:31

Do your PCs use your internal DNS server, or do they use another one (e.g. the one from your ISP)?


All times are GMT +2. The time now is 18:48.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.