HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Postfix, squirrelmail IN, OUT OK cant send from outlook (http://www.howtoforge.com/forums/showthread.php?t=27007)

almeister9 22nd September 2008 06:21

Postfix, squirrelmail IN, OUT OK cant send from outlook
 
I have successfully completed the Howto by Falko on mail server on Ubuntu 8.04 with virtual domains.
I can administer with phpmyadmin.
I can log into squirrelmail and can send to external email addresses. I can send from external email and it is received in squirrelmail. I have tried to setup outlook to connect to it (on same LAN) and I can download the emails to outlook OK but I cant send.
I get a "network password" popup which doesnt accept my username (email account) and password. I know these are correct because I can log into squirrelmail with them and outlook can use them to get mail via POP3.

my mail log says this
Quote:

Sep 22 11:48:27 smail postfix/smtpd[5183]: warning: 10.1.1.2: address not listed for hostname localhost
Sep 22 11:48:27 smail postfix/smtpd[5183]: connect from unknown[10.1.1.2]
Sep 22 11:48:27 smail postfix/smtpd[5183]: warning: unknown[10.1.1.2]: SASL LOGIN authentication failed: authentication failure
Sep 22 11:48:27 smail postfix/smtpd[5183]: lost connection after AUTH from unknown[10.1.1.2]
Sep 22 11:48:27 smail postfix/smtpd[5183]: disconnect from unknown[10.1.1.2]
Sep 22 11:48:29 smail postfix/smtpd[5175]: warning: 10.1.1.2: address not listed for hostname localhost
Sep 22 11:48:29 smail postfix/smtpd[5175]: connect from unknown[10.1.1.2]
Sep 22 11:48:29 smail postfix/smtpd[5175]: lost connection after UNKNOWN from unknown[10.1.1.2]
Sep 22 11:48:29 smail postfix/smtpd[5175]: disconnect from unknown[10.1.1.2]
Sep 22 11:48:29 smail postfix/smtpd[5183]: warning: 10.1.1.2: address not listed for hostname localhost
Sep 22 11:48:29 smail postfix/smtpd[5183]: connect from unknown[10.1.1.2]
Sep 22 11:48:29 smail postfix/smtpd[5183]: lost connection after CONNECT from unknown[10.1.1.2]
Sep 22 11:48:29 smail postfix/smtpd[5183]: disconnect from unknown[10.1.1.2]
Sep 22 11:49:30 smail postfix/smtpd[5175]: warning: 10.1.1.2: address not listed for hostname localhost
Sep 22 11:49:30 smail postfix/smtpd[5175]: connect from unknown[10.1.1.2]
Sep 22 11:49:30 smail postfix/smtpd[5175]: warning: unknown[10.1.1.2]: SASL LOGIN authentication failed: authentication failure
Sep 22 11:49:30 smail postfix/smtpd[5175]: lost connection after AUTH from unknown[10.1.1.2]
Sep 22 11:49:30 smail postfix/smtpd[5175]: disconnect from unknown[10.1.1.2]
I noticed in /var/log/auth.log
Quote:

Sep 22 13:33:39 smail saslauthd[5045]: pam_mysql - required option "db" is not set
Sep 22 13:33:40 smail saslauthd[5045]: DEBUG: auth_pam: pam_authenticate failed: Error in service module
Sep 22 13:33:40 smail saslauthd[5045]: do_auth : auth failure: [user=xxxxxxx@scribalpublishingmail.com.au] [service=smtp] [real
m=scribalpublishingmail.com.au] [mech=pam] [reason=PAM auth error]
my /etc/pam.d/smtp
Quote:

auth required pam_mysql.so user=xxxxxxx passwd=xxxxxxxx host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=xxxxxxx passwd=xxxxxxx host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
(usernames and passwords are correct but edited in post)
/etc/postfix/sasl/smtpd.conf
Quote:

pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: xxxxxxx
sql_passwd: xxxxxxx
sql_database: mail
sql_select: select password from users where email = '%u'
EVERYTHING else is working though.

In outlook I have enabled "SMTP requires authentication" but no joy.
in the setup I have ticked "outgoing server use same credntials as incoming"

I am so close now it hurts.
Any help would be greatly appreciated.
Thanx in Advance.

almeister9 22nd September 2008 12:40

Grrrrrr....but at least know I think I know
 
As I read in another post, my mail_admin's password has a '#' character in it
so in /etc/pam.d/smtp, everything after the start of the password is ignored, hence "db" is not set. I am getting so used to reformatting and doing it again that I think it will be quicker than trying to find all the instances and changing them. It makes sense though.
We live, we learn.
Cheers all.


All times are GMT +2. The time now is 15:33.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.