HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Can't Login to mail server (http://www.howtoforge.com/forums/showthread.php?t=26875)

speedstic 16th September 2008 15:52

Can't Login to mail server
 
Hello All,

I've installed ISPConfig 2.2.5 no problem, but after struggling with the DNS not working, i decided to use an external DNS server.
Now that I have that working, I am unable to login to the mail server from a client, e.g. Outlook Express, using either POP3 or IMAP, says "Password Rejected".
I removed the username prefix as I am only using one domain, I tried testing using postmaster@domain.com, with username postmaster and I can't login to the server.
This is what the logs look like:
mail.log-
Sep 16 09:24:43 ispconfig courierpop3login: Connection, ip=[::ffff:192.168.123.1]
Sep 16 09:24:48 ispconfig courierpop3login: LOGIN FAILED, ip=[::ffff:192.168.123.1]

Anyone have any ideas on how to solve this problem?
Any help is appreciated.

Br8knitOFF 16th September 2008 18:53

Dumb question, but did you create that mail user for the domain?

Check /etc/passwd for the mail account you're trying to login with- if it's not there, you haven't created the mail account for the domain...

//Todd

speedstic 16th September 2008 22:06

Yes I've already created the mail users and they are in my /etc/passwd.

Is there anything in any configuration file that may point to why I can't connect?
E.g. I've noticed that there are two entried in my /etc/postfix/main.cf for the same key.
mydestination = ispconfig.posted-jobs.com, localhost.posted-jobs.com, , localhost
AND at the very bottom of the main.cf there is another
mydestination = /etc/postfix/local-host-names
I didn't add that second one.

Br8knitOFF 16th September 2008 22:23

The second entry gets added by ispconfig- I'd comment out the first one.

Have you tried this:
http://www.postfix.org/SASL_README.html#server_test

Also- ditch Outlook Express. It's a sorry excuse for a mail client.

Go grab yourself a copy of Thunderbird...
http://www.mozilla.org/

//Todd

speedstic 16th September 2008 23:44

its not a matter of not being able to send emails, I have another smtp server to do that for me, I can't even login to any mail client (I know OE sux, just using it to test).
Maybe I'll just do a re-install and see what's what then.

Br8knitOFF 16th September 2008 23:47

Try the username created by ISPConfig for that user. (i.e. web4_postmaster)

Take a look at your /etc/passwd for the actual user name...

//Todd


All times are GMT +2. The time now is 08:40.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.