HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   ISPConfig stuck with error: The URL is not reachable! (http://www.howtoforge.com/forums/showthread.php?t=26858)

adobe 15th September 2008 23:51

ISPConfig stuck with error: The URL is not reachable!
 
Hello,

I am trying to install ISPConfig Control Panel onto my Debian 4.0 Etch server, so I followed this guide first in preparing my server for ISPConfig -> http://www.howtoforge.com/perfect_setup_debian_etch

Once that was complete, I was following this guide here http://www.ispconfig.org/manual_installation.htm and im at the stage where it asks me this question:

Quote:

All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
OK
Please enter your MySQL user:root
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig):db_ispconfig
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):xxx.xxx.xxx.xxx
OK
Please enter the host name (e.g. www):www
Please enter the domain (e.g. xyz.de):mydomain.com
The URL is not reachable!
Since, I am trying to setup my server to run on "mydomain.com", i gave those url, it errors like so:

Quote:

The URL is not reachable!
The ./setup script is confusing, why would it ask for a domain name to run the ispconfig, if it's the first time i am actually running the ispconfig so i can create the nameserver for the "mydomain.com" and have it point to server.

falko 16th September 2008 18:42

www.mydomain.com must already be pingable when you install ISPConfig because the installer tries to ping it to verify the address. As a workaround, you can add www.mydomain.com to /etc/hosts for now.

adobe 18th September 2008 05:42

Out of curiosity, what if i were to enter the address as localhost ?

Will the ISPConfig forever be locked to http://localhost:81

or is it possible to edit some config and have it working on desired domain name?

Quote:

As a workaround, you can add www.mydomain.com to /etc/hosts for now.
how does the entry on /etc/hosts supposed to look like for "www.mydomain.com" ?

Also, do i have to edit my domain name and have it point to my server ip or something using my domain registrar e.g. Godaddy or setting the /etc/hosts file alone is enough???

adobe 18th September 2008 05:46

Okay, here's a new problem i discovered post-installation.

When ever I login, I get this error:

Quote:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (12) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (12) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/lib/classes/ispconfig_auth.lib.php on line 99
When I reboot my server, the error goes away and then somehow, it creeps up again.

Does anyone know a permanent fix to this problem, instead of server reboot every time this error comes on?

till 18th September 2008 11:29

This means just that either the mysql login details were wrong that you entered in the ispconfg installer or that the mysql database is not running.


All times are GMT +2. The time now is 00:59.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.