HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   How to create Ubuntu guest (http://www.howtoforge.com/forums/showthread.php?t=26827)

satimis 14th September 2008 16:40

How to create Ubuntu guest
 
Hi folks.


Host - Debian Etch
Xen


I tried to create an Ubuntu Hardy guest with following steps but
without success.


# cp /etc/xen-tools/xen-tools.conf /etc/xen-tools/xen-tools-ubuntu.conf


# xen-create-image --hostname=xen3.satimis.com --size=2Gb --swap=256Mb
--ide \
> --ip=192.168.0.113 --netmask=255.255.255.0 --gateway=192.168.0.1--force \
> --dir=/vserver --memory=32Mb --arch=i386
--kernel=/boot/vmlinuz-2.6.18-xen \
> --debootstrap --dist=hardy
--config-file=/etc/xen-tools/xen-tools-ubuntu.conf \
> --mirror=http://ftp.hostrino.com/pub/ubuntu/ --passwd
Code:

Unknown option: config-file

  We're trying to configure an installation of hardy in
 /vserver - but there is no hook directory for us to use.

  This means we don't know how to configure this installation.

  We'd expect the hook directory to be : /usr/lib/xen-tools/hardy.d

  Aborting.


Logfile produced at:
        /var/log/xen-tools/xen3.satimis.com.log


Please advise how to make use of "/usr/lib/xen-tools/hardy.d"? What will be the correct steps. TIA


B.R.
satimis

falko 15th September 2008 13:07

Does the directory /vserver exist?

satimis 15th September 2008 13:27

Quote:

Originally Posted by falko (Post 145161)
Does the directory /vserver exist?

Yes.


$ ls -al /vserver/
Code:

total 12
drwxr-xr-x  3 root root 4096 2008-09-13 04:39 .
drwxr-xr-x 23 root root 4096 2008-09-12 23:19 ..
drwxr-xr-x  5 root root 4096 2008-09-14 07:52 domains


B.R.
satimis

falko 16th September 2008 18:07

Ok, I think that maybe hardy is not yet supported. What's the output of
Code:

ls -la /usr/lib/xen-tools
?

satimis 16th September 2008 18:37

Quote:

Originally Posted by falko (Post 145355)
Ok, I think that maybe hardy is not yet supported. What's the output of
Code:

ls -la /usr/lib/xen-tools
?

# ls -la /usr/lib/xen-tools/
Code:

total 64
drwxr-xr-x  7 root root  4096 2008-09-16 09:25 .
drwxr-xr-x 128 root root 36864 2008-09-14 06:32 ..
drwxr-xr-x  2 root root  4096 2008-09-12 22:41 centos4.d
-rw-r--r--  1 root root  2658 2006-11-19 05:51 common.sh
lrwxrwxrwx  1 root root    8 2008-09-12 22:41 dapper.d -> ubuntu.d
drwxr-xr-x  2 root root  4096 2008-09-12 22:41 debian.d
lrwxrwxrwx  1 root root    8 2008-09-12 22:41 edgy.d -> ubuntu.d
lrwxrwxrwx  1 root root    8 2008-09-12 22:41 etch.d -> debian.d
drwxr-xr-x  2 root root  4096 2008-09-12 22:41 fedora.d
drwxr-xr-x  2 root root  4096 2008-09-12 22:41 gentoo.d
lrwxrwxrwx  1 root root    8 2008-09-12 22:41 sarge.d -> debian.d
lrwxrwxrwx  1 root root    8 2008-09-12 22:41 sid.d -> debian.d
lrwxrwxrwx  1 root root    8 2008-09-12 22:41 stentz.d -> fedora.d
drwxr-xr-x  2 root root  4096 2008-09-16 08:57 ubuntu.d

hardy is NOT there.


Tried both dapper and edgy. All fail


# tail /var/log/xen-tools/xen5.satimis.com.log
Code:

Copying files from new installation to host. Copying files from /tmp/IxWnj3F2Gr/var/cache/apt/archives -> /var/cache/apt/archives
Done
Done
The installation of the new system appears to have failed.

There is no '/bin/ls' installed in the new installation directory
Done
System installation failed.  Aborting


I don't understand "There is no '/bin/ls' installed in the new installation directory". What does it mean?


B.R.
satimis

falko 17th September 2008 17:49

Quote:

Originally Posted by satimis (Post 145386)
hardy is NOT there.

This means it's not supported.


Quote:

Originally Posted by satimis (Post 145386)
# tail /var/log/xen-tools/xen5.satimis.com.log
Code:

Copying files from new installation to host. Copying files from /tmp/IxWnj3F2Gr/var/cache/apt/archives -> /var/cache/apt/archives
Done
Done
The installation of the new system appears to have failed.

There is no '/bin/ls' installed in the new installation directory
Done
System installation failed.  Aborting


I don't understand "There is no '/bin/ls' installed in the new installation directory". What does it mean?


B.R.
satimis

What are the outputs of
Code:

ls -la /usr/lib/xen-tools/ubuntu.d/
and
Code:

df -h
?

satimis 17th September 2008 18:38

Quote:

Originally Posted by falko (Post 145532)
This means it's not supported.

What are the outputs of
Code:

ls -la /usr/lib/xen-tools/ubuntu.d/
and
Code:

df -h
?


# ls -la /usr/lib/xen-tools/ubuntu.d/
Code:

total 64
drwxr-xr-x 2 root root 4096 2008-09-16 08:57 .
drwxr-xr-x 7 root root 4096 2008-09-16 09:25 ..
-rwxr-xr-x 1 root root  480 2006-11-19 05:51 10-generate-locale
-rwxr-xr-x 1 root root  482 2006-11-19 05:51 15-disable-hwclock
-rwxr-xr-x 1 root root 1709 2006-11-19 05:51 20-setup-apt
-rwxr-xr-x 1 root root  907 2006-11-19 05:51 25-disable-tls
-rwxr-xr-x 1 root root  930 2006-11-19 05:51 30-fix-inittab
-rwxr-xr-x 1 root root 2630 2006-11-19 05:51 35-setup-users
-rwxr-xr-x 1 root root 2505 2006-11-19 05:51 40-setup-networking
-rwxr-xr-x 1 root root 1783 2006-11-19 05:51 50-setup-hostname
-rwxr-xr-x 1 root root  813 2006-11-19 05:51 60-copy-host-files
-rwxr-xr-x 1 root root  729 2006-11-19 05:51 65-copy-user-files
-rwxr-xr-x 1 root root  708 2006-11-19 05:51 70-install-ssh
-rwxr-xr-x 1 root root  929 2006-11-19 05:51 80-install-modules
-rwxr-xr-x 1 root root 1703 2006-11-19 05:51 90-make-fstab
-rwxr-xr-x 1 root root  485 2006-11-19 05:51 99-clean-image
lrwxrwxrwx 1 root root    5 2008-09-16 08:57 hardy -> hardy
lrwxrwxrwx 1 root root    7 2008-09-16 08:48 hardy.d -> hardy.d


# df -h
Code:

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda1            145G  11G  127G  8% /
tmpfs                1.7G    0  1.7G  0% /lib/init/rw
udev                  10M  56K  10M  1% /dev
tmpfs                1.7G    0  1.7G  0% /dev/shm


satimis

falko 18th September 2008 19:05

Quote:

Originally Posted by satimis (Post 145554)
# ls -la /usr/lib/xen-tools/ubuntu.d/
Code:


lrwxrwxrwx 1 root root    5 2008-09-16 08:57 hardy -> hardy
lrwxrwxrwx 1 root root    7 2008-09-16 08:48 hardy.d -> hardy.d

satimis

Did you create these symlinks? They're pointing to themselves, so you've created a loop. Please delete them.

satimis 19th September 2008 08:30

Quote:

Originally Posted by falko (Post 145706)
Did you create these symlinks? They're pointing to themselves, so you've created a loop. Please delete them.

Deleted the loop.


$ ls -l /usr/lib/xen-tools/ubuntu.d/
Code:

total 56
-rwxr-xr-x 1 root root  480 2006-11-19 05:51 10-generate-locale
-rwxr-xr-x 1 root root  482 2006-11-19 05:51 15-disable-hwclock
-rwxr-xr-x 1 root root 1709 2006-11-19 05:51 20-setup-apt
-rwxr-xr-x 1 root root  907 2006-11-19 05:51 25-disable-tls
-rwxr-xr-x 1 root root  930 2006-11-19 05:51 30-fix-inittab
-rwxr-xr-x 1 root root 2630 2006-11-19 05:51 35-setup-users
-rwxr-xr-x 1 root root 2505 2006-11-19 05:51 40-setup-networking
-rwxr-xr-x 1 root root 1783 2006-11-19 05:51 50-setup-hostname
-rwxr-xr-x 1 root root  813 2006-11-19 05:51 60-copy-host-files
-rwxr-xr-x 1 root root  729 2006-11-19 05:51 65-copy-user-files
-rwxr-xr-x 1 root root  708 2006-11-19 05:51 70-install-ssh
-rwxr-xr-x 1 root root  929 2006-11-19 05:51 80-install-modules
-rwxr-xr-x 1 root root 1703 2006-11-19 05:51 90-make-fstab
-rwxr-xr-x 1 root root  485 2006-11-19 05:51 99-clean-image


$ ls -l /usr/lib/xen-tools/
Code:

total 24
drwxr-xr-x 2 root root 4096 2008-09-12 22:41 centos4.d
-rw-r--r-- 1 root root 2658 2006-11-19 05:51 common.sh
lrwxrwxrwx 1 root root    8 2008-09-12 22:41 dapper.d -> ubuntu.d
drwxr-xr-x 2 root root 4096 2008-09-12 22:41 debian.d
lrwxrwxrwx 1 root root    8 2008-09-12 22:41 edgy.d -> ubuntu.d
lrwxrwxrwx 1 root root    8 2008-09-12 22:41 etch.d -> debian.d
drwxr-xr-x 2 root root 4096 2008-09-12 22:41 fedora.d
drwxr-xr-x 2 root root 4096 2008-09-12 22:41 gentoo.d
lrwxrwxrwx 1 root root    8 2008-09-12 22:41 sarge.d -> debian.d
lrwxrwxrwx 1 root root    8 2008-09-12 22:41 sid.d -> debian.d
lrwxrwxrwx 1 root root    8 2008-09-12 22:41 stentz.d -> fedora.d
drwxr-xr-x 2 root root 4096 2008-09-18 23:04 ubuntu.d


Performed following test but still failure.


# xen-create-image --hostname=xen7.satimis.com --size=2Gb --swap=256Mb --ide --ip=192.168.0.117--netmask=255.255.255.0 --gateway=192.168.0.1 --force --dir=/vserver --memory=32Mb --arch=i386 --kernel=/boot/vmlinuz-2.6.18-xen --debootstrap --dist=dapper --mirror=http://archive.ubuntu.com/ubuntu/ --passwd
Code:

General Infomation
--------------------
Hostname      :  xen7.satimis.com
Distribution  :  dapper
Fileystem Type :  ext3

Size Information
----------------
Image size    :  2Gb
Swap size      :  256Mb
Image type    :  sparse
Memory size    :  32Mb
Kernel path    :  /boot/vmlinuz-2.6.18-xen

Networking Information
----------------------
IP Address 1  : 192.168.0.117--netmask=255.255.255.0
Netmask        : 255.255.255.0
Gateway        : 192.168.0.1

WARNING
-------
Loopback module not loaded and you're using loopback images
Run the following to load the module:

modprobe loop loop_max=255


Creating swap image: /vserver/domains/xen7.satimis.com/swap.img
Done

Creating disk image: /vserver/domains/xen7.satimis.com/disk.img
Done

Creating ext3 filesystem on /vserver/domains/xen7.satimis.com/disk.img
Done

Installing your system with debootstrap mirror http://archive.ubuntu.com/ubuntu/
Done
System installation failed.  Aborting


Logfile produced at:
        /var/log/xen-tools/xen7.satimis.com.log


# tail /var/log/xen-tools/xen7.satimis.com.log
Code:


Copying files from new installation to host.
Copying files from /tmp/GK1IqjXCQ1/var/cache/apt/archives -> /var/cache/apt/archives
Done
Done
The installation of the new system appears to have failed.

There is no '/bin/ls' installed in the new installation directory
Done
System installation failed.  Aborting


B.R.
satimis

falko 20th September 2008 13:01

Can you run
Code:

modprobe loop loop_max=255
and try again?


All times are GMT +2. The time now is 22:35.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.