HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Spamsnake - Unable to received mail - Able to send mail (http://www.howtoforge.com/forums/showthread.php?t=26826)

debuguser 14th September 2008 14:34

Spamsnake - Unable to received mail - Able to send mail
 
Good morning,

Please help!!!

I tried to setup a spamsnake to filter all incoming mails before relaying to our Exchange server which are located behind a firewall. The Spamsnake is located in a DMZ subnet and my Exchange is located in other subnet. However I am unable to receive mail from external either I have set all port forwarding correctly as I am able to received test mails from Spamsnake. I am able to send out mail. Please see below schema for my setup

Internet --> Router --> Firewall -->DMZ (Spamsnake 192.168.3.1)-->Exchange (192.168.0.23)

In postfix I set relay_recipients, the transport_map, the relay_domains. I postmap all these files.

Please help!!!

falko 15th September 2008 13:05

Any errors in the mail log?

Rocky 15th September 2008 14:37

Have you setup the proper MX records for your spamsnake?

debuguser 15th September 2008 15:15

I have the below message

Can't call method "tie_db_readonly" on an undefined value at /usr/share/perl5/Mail/SpamAssassin/Bayes.pm line 1123.

Enabling SpamAssassin auto-whitelist functionality...
Process did not exit clearly, returned 255 with signal 0

postfix/smtpd [7699]: warning: database /etc/postfix/relay_recipients.db is older than source file /etc/postfix/relay_recipients >>> I presume this error can be fix by postmap command right?

I have one error message that popup on the screen every morning in regard with MailWatch.pm but I am unable to trace the log.

Regards,

debuguser 15th September 2008 15:27

Quote:

Originally Posted by Rocky (Post 145190)
Have you setup the proper MX records for your spamsnake?

Good morning,

The mail server that I mount have a MX record hosted as my ISP, I check this morning when In read yr. post using the below command

# dig mx mailserver.domain.com

However plaese tell me how to check if my MX is in my BIND

Thanks,

Rocky 15th September 2008 16:09

I think you have to do:
dig mx domain.com

That should list your mx records.

You have to postmap your relay_recipients file and that will fix the relay error.

For the bayes issues, make sure you have the following in your spam.assassin.prefs.conf file and make sure to change the values to match your setup:

#Bayes DB Connection
bayes_store_module Mail::SpamAssassin::BayesStore::SQL
bayes_sql_dsn DBI:mysql:sa_bayes:localhost
bayes_sql_username username
bayes_sql_password password
bayes_sql_override_username root

debuguser 15th September 2008 18:17

I think the problem that I have is in named.conf in /var/lib/named/etc/bind/named.conf, I am not sure if I do right so can someone give me a sample or shoiw me how-to process.

Thanks

debuguser 15th September 2008 20:21

Need a working sample of named.conf
 
Can someone provide a working sample of named.conf with MX and A record so I can resolve this problem.
Please copy and paste or reply with attachment.

Thanks

Rocky 15th September 2008 21:27

hey,

Who's the host of your DNS? They would have to create the records for you. You will need a host record(A) and an MX record for your spamsnake.

The A record makes it available online and the MX records directs mails over to it.

You have to get your DNS host to do this for you.

debuguser 15th September 2008 21:40

Quote:

Originally Posted by Rocky (Post 145256)
hey,

Who's the host of your DNS? They would have to create the records for you. You will need a host record(A) and an MX record for your spamsnake.

The A record makes it available online and the MX records directs mails over to it.

You have to get your DNS host to do this for you.


Thanks for yr. reply.

I have a 3 MX host and recorded at my ISP, I have 2 A record but I don't known how-to put in the named.conf, I use MS Exchange so Linux Mail server is new to me.

Can you provide me a "WORKING" sample of the names.conf

Thanks,


All times are GMT +2. The time now is 17:51.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.