HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Setting up Bind on CentOS 5.2 simplified webservers setup newb question. (http://www.howtoforge.com/forums/showthread.php?t=26490)

tritone 1st September 2008 06:57

Setting up Bind on CentOS 5.2 simplified webservers setup newb question.
 
So I followed the simple setup guide for Bind/Apache on Centos as posted here -> http://www.howtoforge.com/creating-y...apache-centos5. BIND is setup with chroot as well, I made the symlinks as recommended and double checked them a few times.

I got everything configured per the tutorial... I think, but when I try and set my domain's (psychpdx.com) name servers to my newly created DNS server I get this error:

"Unable to update nameservers: Nameserver [ns2.psychpdx.com] doesn't exist at the registry "

A little more about my setup that may be the cause of the problem. I have Quest DSL and the servers IP address is set to my local network address 192.192.0.127, I opened the ports on the DSL modem/router to allow in traffic for DNS, SSH, FTP, and web(port 80). I can SSH to my server in from outside my local network to the IP address quest gives me so opening those ports seems to direct traffic where it should. I am not sure if that is what I should be setting in my zone file for an ip, currently I have the internal network IP's?

Here is my zone file per my first many tries, oh and named does start without complaining:

$TTL 14400
@ 86400 IN SOA ns1.psychpdx.com. admin@psychpdx.com. (
2008021501 ; serial, todays date+todays
86400 ; refresh, seconds
7200 ; retry, seconds
3600000 ; expire, seconds
86400 ) ; minimum, seconds
psychpdx. 86400 IN NS ns1.psychpdx.com.
psychpdx. 86400 IN NS ns2.psychpdx.com.
ns1 IN A 192.192.0.127
ns2 IN A 192.192.0.127
website.com. IN A 192.192.0.127
localhost.website.com. IN A 127.0.0.1
psychpdx.com. IN MX 0 psychpdx.com.
mail IN CNAME psychpdx.com.
www IN CNAME psychpdx.com.
ftp IN A 192.192.0.127


Any ideas where to start troubleshooting this? Sorry if this is super basic but I am pretty new to this stuff.

Cheers!

This site is amazing by the way :)

tritone 1st September 2008 08:19

I think I figured out my problem, I need to register my domain name at my registrar as a name server, which makes sense with the error. Like I said I am new here :)


All times are GMT +2. The time now is 12:37.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.