HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Developers' Forum (http://www.howtoforge.com/forums/forumdisplay.php?f=18)
-   -   DNSManager Bug or Feature Request (http://www.howtoforge.com/forums/showthread.php?t=26291)

jasonathowtoforge 25th August 2008 20:16

DNSManager Bug or Feature Request
 
Don't know if this is a Bug or Feature Request, but parsing the creation of DNS entries specifying a trailing . would be helpful. In 2.2.23, I created some external MX records including a trailing dot "." and ISPConfig seemed to add a second one. Bind didn't care much for it... Maybe a `named-checkconf -z` for a sanity check after a change is made.

falko 26th August 2008 19:09

I've added this to our bugtracker.

jasonathowtoforge 26th August 2008 20:37

It appears to be a common configuration task to include the "." at the end of a record. Google Apps mail configuration uses the trailing dot (which is technically correct, denoting the highest level root for the FQDN but which is left out of many records and left up to the dns resolver to append).

So if you followed the Google instructions you'd get bit by this bug, like this guy and myself were:
http://www.howtoforge.com/forums/showthread.php?t=21145

Judging by the popularity of that thread it is common enough.

Also you'll see in syslog the bind entries:
dns_rdata_fromtext: <zone>:13: near 'ASPMX.L.GOOGLE.COM..': empty label
zone <zone>/IN: loading from master file <file> failed: empty label


All times are GMT +2. The time now is 19:06.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.