HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   a backup server by RSYNC + SSH in a chrooted environment (http://www.howtoforge.com/forums/showthread.php?t=26206)

paguira 21st August 2008 17:48

a backup server by RSYNC + SSH in a chrooted environment
 
Good morning,
I try to set up a backup server by RSYNC + SSH in a chrooted environment.
Only SCP, SFTP and RSYNC will be used and usable for users.
And I want to establish quotas for these users.
I use CentOS5 note Fedora
I tested script:

http://www.howtoforge.com/chroot_ssh_sftp_fedora7_p2

But in both cases, when I connect with the user's account I have an immediate disconnection

I tested the script "make_chroot_jail.sh" according to the following procedure:
http://www.howtoforge.com/chroot_ssh_sftp_fedora7_p2

I had the following problem:
Quote:

sudo: user: sorry, you must have a tty to run sudo; TTY = unknown; PWD = /home/chroot/home/user; USER = root ...
What I set like this:
comment "requiretty Defaults" in "/etc/sudoers"

ld-lsb.so.1 is replaced by ld-lsb.so.3 in the script "make_chroot_jail.sh" REDHAT

Nevertheless I find it impossible to connect me with ssh and WinSCP, I have an immediate disconnection, my logs:

Quote:

Aug 13 15:49:24 rsync sshd[2797]: Accepted password for utilisateur from 192.168.23.199 port 1116 ssh2
Aug 13 15:49:24 rsync sshd[2797]: pam_unix(sshd:session): session opened for user utilisateur by (uid=0)
Aug 13 15:49:24 rsync sshd[2799]: subsystem request for sftp
Aug 13 15:49:24 rsync sudo: utilisateur : TTY=unknown ; PWD=/home/chroot/home/utilisateur ; USER=root ; COMMAND=/usr/sbin/chroot /home/jail /bin/su - utilisateur -c /usr$
Aug 13 15:49:24 rsync sshd[2797]: pam_unix(sshd:session): session closed for user utilisateur

P.S: excused my English, I'm french Reply With Quote

falko 22nd August 2008 13:21

Did you get any errors when you ran the script?
Is the chrooted user listed in /home/chroot/etc/passwd and /home/chroot/etc/shadow?

paguira 22nd August 2008 14:46

I have no error.

Except with "libxcrypt"
But according to the tutorial "HowForge" This is not a problem

I forget to say that I'm on CentOS 5

/home/chroot/etc/passwd


Code:

root:x:0:0:root:/root:/bin/bash
utilisateur:x:500:500::/home/utilisateur:/bin/bash

/home/chroot/etc/shadow

Code:

utilisateur:$1$3lXATEfy$.ttLr/IFf.3VPXo4qjgTq0:14112:0:99999:7:::

falko 23rd August 2008 16:44

Not sure if this is the problem, but did you disable SELinux?


All times are GMT +2. The time now is 18:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.