HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=4)
-   -   ISPConfig 2.2.24 - Fedora 9 - htaccess - mod_rewrite (http://www.howtoforge.com/forums/showthread.php?t=25843)

ChrisX 7th August 2008 19:07

ISPConfig 2.2.24 - Fedora 9 - htaccess - mod_rewrite
 
I have two problems today.

I installed Fedora 9 using "The Perfect Server" and then installed ISPConfig 2224.

My first question is, how do I get ISPConfig to recognize individual .htaccess files?

I tried changing the AllowOverride parm from None to All, but it still doesn't work.

How exactly, including paths and specific file names, do I get this to work?


My second question then becomes how do I get this version of ISPConfig to utilize
mod_rewrite? I installed both Joomla and Pligg and both keep failing saying that they can't
recognize the files. This is naturally because .htaccess doesn't work, but while I'm here I also want to know
what exactly do I need to put into the "Apache Directives" field to get this to work?

I once had this all working on Fedora 7 and ISPConfig 2221, but I can't seem to duplicate it.

Any help would be greatly appreciated.

Thank You

ChrisX 8th August 2008 05:38

Nevermind :)

vi /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf

Find the server, edit the AllowOverride statement. Works like a charm.

Why did I need to do it there? I checked "Python" in the ispconfig page for this site.

Even if you edit this, the next time you save the page in ISPConfig, it will put it back, no matter what is in "Apache Directives".

Once I unchecked "Python", and added this to Apache Directives....

<IfModule mod_python.c>
<Directory /var/www/web3/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride all
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

Everything works now. Python, and AllowOverride.

Unless I missed something, this is a bug.

falko 8th August 2008 16:45

I've added this to our bugtracker. We will check this.

ChrisX 8th August 2008 18:24

Quote:

Originally Posted by falko (Post 140025)
I've added this to our bugtracker. We will check this.

Thank You

I really do appreciate what you folks have done with regard to the "Perfect Server" tutorials. The reason is not simply because it takes you step by step, I didn't need that so much.

The reason is because when discussing issues, not only can you point to releases in an environment as you normally would, but you can point to details on how the environment was set up. The ability to do that is where the real value is. It makes it so much easier when everyone has a common frame of reference.

I'm also now glad I reported my first bug! I hate using open source without doing something to "earn" the privilege. ISPConfig is an awesome app. It needs some "curtains and a bit of paint" ;) , but it really does the job very well.

My suggestion is to clean up the interface, and then sell add-ons like a payment gateway for Linux hosting providers. Maybe even create some Joomla components/plugins or something so that it can be easily integrated into a content manager. That way hosts can have a better presentation.
(It would also fund the project pretty well. No harm in selling commercially oriented add-ons to pay some bills)

It would be awesome if you folks could give C-Panel and Plesk some serious competition.

Oh yeah, I should probably create another thread, but this is a small issue. I created a "Reseller" and forgot to set the permissions for MySql and other things. When I tried to create a site under that reseller, it failed saying the reseller didn't have the right to those services. The problem is, it created a "web1" and sent it off to never-never land. I could not see it to delete it, but it took the "web1" spot. So the next site I created was "web2", but it was the only one that could be seen.

I don't know if that's a known issue or not, but now you have the only two issues I've seen so far with this release.

Thanks again!

falko 9th August 2008 11:14

Quote:

Originally Posted by ChrisX (Post 140066)
I created a "Reseller" and forgot to set the permissions for MySql and other things. When I tried to create a site under that reseller, it failed saying the reseller didn't have the right to those services. The problem is, it created a "web1" and sent it off to never-never land. I could not see it to delete it, but it took the "web1" spot. So the next site I created was "web2", but it was the only one that could be seen.

This happens because the data is stored in the db before the checks are done. This cannot be changed with the framework that ISPConfig 2 is using.

falko 18th August 2008 15:59

Quote:

Originally Posted by ChrisX (Post 139933)
Nevermind :)

vi /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf

Find the server, edit the AllowOverride statement. Works like a charm.

Why did I need to do it there? I checked "Python" in the ispconfig page for this site.

Even if you edit this, the next time you save the page in ISPConfig, it will put it back, no matter what is in "Apache Directives".

Once I unchecked "Python", and added this to Apache Directives....

<IfModule mod_python.c>
<Directory /var/www/web3/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride all
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>

Everything works now. Python, and AllowOverride.

Unless I missed something, this is a bug.

I've now replaced
Code:

AllowOverride None
with
Code:

AllowOverride Indexes AuthConfig Limit FileInfo
in SVN.


All times are GMT +2. The time now is 21:58.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.