HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   VSFTPD can not close uploaded files (http://www.howtoforge.com/forums/showthread.php?t=25700)

rdmandel 1st August 2008 19:12

VSFTPD can not close uploaded files
 
I have been running VSFTPD on Ubuntu for some time, and the problem persists. When I upload files of decent size to the server, the server does not seem to close or upload the file properly. Or at least it thinks it is not closed or uploaded properly, so after a bit, it tries again. Usually, it is successful after uploading another version of the file with an "_old" version. Does not happen with smallish files.

Here is my conf file:

background=YES
listen=YES
hide_ids=yes
pasv_min_port=49155
pasv_max_port=65535
anonymous_enable=NO
local_enable=YES
local_umask=022
write_enable=YES
pam_service_name=vsftpd
chroot_local_user=YES
use_localtime=yes
chroot_list_file=/etc/vsftpd.chroot_list
port_enable=YES
xferlog_enable=YES
log_ftp_protocol=YES
xferlog_std_format=NO
connect_from_port_20=NO

falko 2nd August 2008 13:44

How big are these files?
I have a similar "problem" when I upload virtual machines (at least 300MB) with WS_FTP to a ProFTPd server. At the end of the upload, I get something like "Blocking call cancelled" instead of a directory listing, but nevertheless the file was uploaded sucessfully, so I don't see this as a problem.

rdmandel 2nd August 2008 19:55

VSFTPD problem
 
Guten tag Falko - Wie gehts?

I do not get an error message. At the end of the upload of a file larger than 65 MB or so, it just seems to hang, doing nothing. After a minute or three it decides there was a problem, so it begins again and renames the old file "old" and tries again. Often it is successful after one or two re-tries, but this makes the upload of multiple files a real pain if one of the files is over that size.

Oddly enough, when I break off the uploads and check the directory, the first file that the client said failed, actually made it ok.

I know the problem so I can tolerate it for my own purposes, but when files come in from customers, the problem is too annoying for them to use my ftp.

Using AceFTP Pro 3 as a client, but I have tried other clients and the results appear to be the same.

falko 3rd August 2008 13:45

Are there any errors in your logs?
Have you tried other FTP servers such as ProFTPd or PureFTPd?

rdmandel 3rd August 2008 19:40

I have not tried other ftp servers.

Log - Nothing too exciting in the logs. Perhaps some communication trouble on some commands from my client.

But also regular time-outs, but then the command seemed to be executed.

FTP command: Client "74.92.219.114", "FEAT"
FTP response: Client "74.92.219.114", "211-Features:"
FTP response: Client "74.92.219.114", " EPRT??"
FTP response: Client "74.92.219.114", " EPSV??"
FTP response: Client "74.92.219.114", " MDTM??"
FTP response: Client "74.92.219.114", " PASV??"
FTP response: Client "74.92.219.114", " REST STREAM??"
FTP response: Client "74.92.219.114", " SIZE??"
FTP response: Client "74.92.219.114", " TVFS??"
FTP response: Client "74.92.219.114", "211 End"

FTP response: Client "74.92.219.114", " XPWD XRMD??"

FTP command: Client "74.92.219.114", "PWD"
FTP response: Client "74.92.219.114", "257 "/www/tt/guest""
FTP command: Client "74.92.219.114", "TYPE I"
Sat FTP response: Client "74.92.219.114", "200 Switching to Binary mode."
FTP command: Client "74.92.219.114", "PASV"
Sat FTP response: Client "74.92.219.114", "227 Entering Passive Mode (192,168,1,106,220,107)"
FTP command: Client "74.92.219.114", "STOR /www/tt/guest/AlbumDemoSetup.exe"
11:17:51 FTP response: Client "74.92.219.114", "150 Ok to send data."
11:19:15 FTP response: Client "74.92.219.114", "421 Timeout."
11:20:07 OK UPLOAD: Client "74.92.219.114",

sayad 4th August 2008 16:04

vsftpd is giving some good offers.After numerous requests, I now have a PayPal button for donations. If you use vsftpd, like it, and think it's worthy of a donation, then click on the Paypal button on the left of the page.


All times are GMT +2. The time now is 08:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.