HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Server Operation (http://www.howtoforge.com/forums/forumdisplay.php?f=5)
-   -   telnet: Unable to connect to remote host: No route to host (http://www.howtoforge.com/forums/showthread.php?t=25611)

leeeonardo 30th July 2008 01:56

telnet: Unable to connect to remote host: No route to host
 
I have Centos 4.4 Server with ISP Config, but I send mail and dont happen nothing. And my logs say:
telnet mx2.hotmail.com 25
telnet: Unable to connect to remote host: No route to host

Thanks for help me.

leeeonardo 30th July 2008 02:25

Jul 29 17:02:49 local postfix/smtpd[24924]: warning: 192.168.1.100: hostname JLRSoftware verification failed: Name or service not known
Jul 29 17:02:49 local postfix/smtpd[24924]: connect from unknown[192.168.1.100]
Jul 29 17:02:49 local postfix/smtpd[24924]: 5F7B7B4181: client=unknown[192.168.1.100], sasl_method=LOGIN, sasl_username=web5_prueba
Jul 29 17:02:49 local postfix/cleanup[24925]: 5F7B7B4181: message-id=<20080730000249.5F7B7B4181@local.jlr-software.com>
Jul 29 17:02:49 local postfix/qmgr[23147]: 5F7B7B4181: from=<prueba@thecoolgangcorp.com>, size=4240, nrcpt=1 (queue active)
Jul 29 17:02:49 local postfix/smtp[24885]: connect to mx3.hotmail.com[65.54.244.72]: No route to host (port 25)
Jul 29 17:02:51 local postfix/smtpd[24924]: disconnect from unknown[192.168.1.100]
Jul 29 17:02:52 local postfix/smtp[24885]: connect to mx4.hotmail.com[65.54.244.232]: No route to host (port 25)
Jul 29 17:02:55 local postfix/smtp[24885]: connect to mx2.hotmail.com[65.54.245.40]: No route to host (port 25)
Jul 29 17:02:58 local postfix/smtp[24885]: connect to mx3.hotmail.com[65.54.244.200]: No route to host (port 25)
Jul 29 17:03:01 local postfix/smtp[24885]: connect to mx2.hotmail.com[65.54.244.168]: No route to host (port 25)

topdog 30th July 2008 10:12

Either your default route does not exist or you have a firewall blocking the connection

leeeonardo 30th July 2008 16:36

I have disabled the firewall and disable SELinux

[root@local /]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

And check that network:

[root@local /]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 3304/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 3010/portmap
tcp 0 0 *:81 *:* LISTEN 3688/ispconfig_http
tcp 0 0 local.jlr-software.c:domain *:* LISTEN 3815/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 3815/named
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 3142/cupsd
tcp 0 0 *:smtp *:* LISTEN 8018/master
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 3815/named
tcp 0 0 *:667 *:* LISTEN 3029/rpc.statd
tcp 0 0 *:imaps *:* LISTEN 3330/dovecot
tcp 0 0 *:pop3s *:* LISTEN 3330/dovecot
tcp 0 0 *:pop3 *:* LISTEN 3330/dovecot
tcp 0 0 *:imap *:* LISTEN 3330/dovecot
tcp 0 0 *:http *:* LISTEN 3713/httpd
tcp 0 0 *:ftp *:* LISTEN 3833/proftpd: (acce
tcp 0 0 *:ssh *:* LISTEN 3188/sshd
tcp 0 0 ::1:rndc *:* LISTEN 3815/named
tcp 0 0 *:https *:* LISTEN 3713/httpd
tcp 0 268 local.jlr-software.com:ssh ::ffff:192.168.1.100:3575 ESTABLISHED 4399/0
tcp 0 0 local.jlr-software.com:pop3 ::ffff:192.168.1.100:1177 TIME_WAIT -

And My Route forwaring the ports to server:

TCP 21, 80, 25, 110, 81, 22, 143, 53
UDP 53

topdog 30th July 2008 17:04

whats the output of
Code:

netstat -nr

leeeonardo 30th July 2008 17:06

[root@local ~]# netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
0.0.0.0 192.168.1.254 0.0.0.0 UG 0 0 0 eth0

topdog 30th July 2008 17:10

i take it 192.168.1.254 is your router ? it could be your ISP blocking port 25 and they want you to use their relay server instead. Try telneting to your ISP's relay servers if it works then you will have to configure your mail server to use them as a smarthost.

leeeonardo 30th July 2008 17:16

Yes, my route is 192.168.1.254. And this is info of my ISP:
Dirección de Internet: 189.176.121.90
Máscara de subred: 255.255.255.255
Puerta de enlace predeterminada: 200.38.193.226
Servidor principal de nombres de dominio: 200.23.242.177
Servidor secundario de nombres de dominio: 200.23.242.185

[root@local ~]# telnet 200.38.193.226 25
Trying 200.38.193.226...
telnet: connect to address 200.38.193.226: No route to host
telnet: Unable to connect to remote host: No route to host

topdog 31st July 2008 08:38

I do not understand spanish but from what i see Puerta de enlace predeterminada is not an smtp server it is your default gateway

You need to ask your ISP for the smtp relay server you are supposed to use especially if you are on DSL


All times are GMT +2. The time now is 00:54.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.