HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Bind stops and cannot be restarted after a slave domain is added (http://www.howtoforge.com/forums/showthread.php?t=253)

jason 14th August 2005 15:16

Bind stops and cannot be restarted after a slave domain is added
 
Good afternoon

Bit of a problem... When I add a slave domain via ISPConfig bind stops and won't start again. The only solution is to reinstall bind9 and work through the debian setup howto.

On a different note. I can only login to webmail using the ISPConfig user name (eg wed4_test) - not the email address I assign. Locally generated mail is received fine and sending mail is not a problem but my test user can't receive any externally generated mail. Any pointers?

Ta

j

falko 14th August 2005 16:00

Quote:

Originally Posted by jason
Good afternoon

Bit of a problem... When I add a slave domain via ISPConfig bind stops and won't start again. The only solution is to reinstall bind9 and work through the debian setup howto.

Any messages in the logs (/var/log/messages or /var/log/syslog)?

Quote:

Originally Posted by jason
On a different note. I can only login to webmail using the ISPConfig user name (eg wed4_test) - not the email address I assign. Locally generated mail is received fine and sending mail is not a problem but my test user can't receive any externally generated mail. Any pointers?

Did you install the webmail package from www.ispconfig.org or another one?

jason 14th August 2005 20:10

Quote:

Any messages in the logs (/var/log/messages or /var/log/syslog)?

/var/log/messages

lots of the below but not much else

Aug 14 15:40:24 jasons -- MARK --


/var/log/syslog (grepped for bind)

Aug 14 13:48:25 jasons named[31060]: starting BIND 9.2.4 -u bind -t /var/lib/named
Aug 14 13:48:25 jasons named[31060]: loading configuration from '/etc/bind/named.conf'
Aug 14 13:48:25 jasons named[31060]: /etc/bind/named.conf:30: unknown option '<'
Aug 14 13:48:25 jasons named[31060]: /etc/bind/named.conf:35: unknown option '<'
Aug 14 13:49:21 jasons named[31189]: starting BIND 9.2.4 -u bind -t /var/lib/named
Aug 14 13:49:21 jasons named[31189]: loading configuration from '/etc/bind/named.conf'
Aug 14 13:49:21 jasons named[31189]: /etc/bind/named.conf:30: unknown option '<'
Aug 14 13:49:21 jasons named[31189]: /etc/bind/named.conf:35: unknown option '<'

Quote:

Did you install the webmail package from www.ispconfig.org or another one?
Yes. I had the same problem as quite a few people who follow the Debian setup tutorial and then install webmail. It been mainly fixed by reading the posts here but not being able to receive mail is quite a big flaw. I suspect the answer may be to add a domain in a config file somewher but I'm not sure where to start. I can give someone a login if need be.

The tutorial is fantastic by the way. I'm new to this and I've learnt a lot from working through it.

falko 14th August 2005 20:50

Quote:

Aug 14 13:48:25 jasons named[31060]: /etc/bind/named.conf:30: unknown option '<'
Aug 14 13:48:25 jasons named[31060]: /etc/bind/named.conf:35: unknown option '<'
There must be syntax errors in /etc/bind/named.conf in line 30 and 35 (look out for "<"). Remove the error and restart named. If you don't know what to do you can post /etc/bind/named.conf here.

Quote:

Yes. I had the same problem as quite a few people who follow the Debian setup tutorial and then install webmail. It been mainly fixed by reading the posts here but not being able to receive mail is quite a big flaw. I suspect the answer may be to add a domain in a config file somewher but I'm not sure where to start. I can give someone a login if need be.
Any messages in /var/log/mail.log? Did you choose the correct format of your mailbox in ISPConfig (mbox vs. Maildir)?
http://www.howtoforge.com/forums/showthread.php?t=200
http://www.howtoforge.com/forums/showthread.php?t=175

jason 14th August 2005 21:42

Quote:

If you don't know what to do you can post /etc/bind/named.conf here.
<!-- BEGIN DYNAMIC BLOCK: named_reverse -->
zone "{ZONE}.in-addr.arpa" {
type master;
file "pri.{ZONE}.in-addr.arpa";
};
<!-- END DYNAMIC BLOCK: named_reverse -->

I think these are the offending lines - the top is 30 and the bottom 35. They look ok though so....


Quote:

Any messages in /var/log/mail.log?
These are the last interesting ones.

Aug 14 17:32:48 jasons postfix/smtpd[2217]: connect from 219-81-152-12.dynamic.tfn.net.tw[219.81.152.12]
Aug 14 17:32:50 jasons postfix/smtpd[2217]: NOQUEUE: reject: RCPT from 219-81-152-12.dynamic.tfn.net.tw[219.81.152.12]: 554 <pp168@so-net.net.tw>: Relay access denied; from=<fgsgmaildsfa@msa.hinet.net> to=<pp168@so-net.net.tw> proto=SMTP helo=<80.87.131.60>
Aug 14 17:32:50 jasons postfix/smtpd[2217]: lost connection after RCPT from 219-81-152-12.dynamic.tfn.net.tw[219.81.152.12]
Aug 14 17:32:50 jasons postfix/smtpd[2217]: disconnect from 219-81-152-12.dynamic.tfn.net.tw[219.81.152.12]
Aug 14 17:36:10 jasons postfix/anvil[2219]: statistics: max connection rate 1/60s for (smtp:219.81.152.12) at Aug 14 17:32:48
Aug 14 17:36:10 jasons postfix/anvil[2219]: statistics: max connection count 1 for (smtp:219.81.152.12) at Aug 14 17:32:48
Aug 14 17:36:10 jasons postfix/anvil[2219]: statistics: max cache size 1 at Aug 14 17:32:48

Otherwise I just get...

Aug 14 20:13:17 jasons courierpop3login: LOGIN, user=web4_test, ip=[::ffff:127.0.0.1]
Aug 14 20:13:17 jasons courierpop3login: LOGOUT, user=web4_test, ip=[::ffff:127.0.0.1], top=2604, retr=0, time=0
Aug 14 20:23:18 jasons courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Aug 14 20:23:18 jasons courierpop3login: LOGIN, user=web4_test, ip=[::ffff:127.0.0.1]
Aug 14 20:23:18 jasons courierpop3login: LOGOUT, user=web4_test, ip=[::ffff:127.0.0.1], top=2604, retr=0, time=0
Aug 14 20:33:19 jasons courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Aug 14 20:33:19 jasons courierpop3login: LOGIN, user=web4_test, ip=[::ffff:127.0.0.1]
Aug 14 20:33:19 jasons courierpop3login: LOGOUT, user=web4_test, ip=[::ffff:127.0.0.1], top=2604, retr=0, time=0

Quote:

Did you choose the correct format of your mailbox in ISPConfig (mbox vs. Maildir)
I'm using Maildir. I followed the directions in the tutorial for Maildir and selected it in ISP Config. Emails are delivered to the mailboxes though so.......

falko 15th August 2005 10:51

Quote:

Originally Posted by jason
<!-- BEGIN DYNAMIC BLOCK: named_reverse -->
zone "{ZONE}.in-addr.arpa" {
type master;
file "pri.{ZONE}.in-addr.arpa";
};
<!-- END DYNAMIC BLOCK: named_reverse -->

I think these are the offending lines - the top is 30 and the bottom 35. They look ok though so....

Did you copy the named.conf template file from /root/ispconfig/isp/conf to /etc/bind??? You cannot do that, it's as template, and all the important content is parsed into it by ISPConfig! :rolleyes:

Quote:

I'm using Maildir. I followed the directions in the tutorial for Maildir and selected it in ISP Config. Emails are delivered to the mailboxes though so.......
You mean, mails arrive in Maildir or in mbox?

jason 15th August 2005 20:43

Quote:

Did you copy the named.conf template file from /root/ispconfig/isp/conf to /etc/bind??? You cannot do that, it's as template, and all the important content is parsed into it by ISPConfig!
You're right! I did :eek: What do I need to do to rectify this?

Quote:

You mean, mails arrive in Maildir or in mbox?
Yeah. The mailbox are all called Maildir. Could it be that postfix tried to deliver mail sent externally to mbox mailboxes that don't exist?

falko 15th August 2005 21:02

Quote:

Originally Posted by jason
You're right! I did :eek: What do I need to do to rectify this?

You can simply create a zone in the DNS Manager, and then /etc/bind/named.conf will be overwritten with a correct file (as long as you've left the original template file in /root/ispconfig/isp/conf.

Quote:

Could it be that postfix tried to deliver mail sent externally to mbox mailboxes that don't exist?
Don't think so. Are there mails in /var/spool mail?

jason 15th August 2005 22:42

Quote:

You can simply create a zone in the DNS Manager, and then /etc/bind/named.conf will be overwritten with a correct file (as long as you've left the original template file in /root/ispconfig/isp/conf.
Where can I get/How do I generate a template file?

Quote:

Are there mails in /var/spool mail?
Only one from the system.

'Subject: Debconf: Configuring ssh -- NOTE: Forwarding of X11 and Authorization disabled by default.'

falko 15th August 2005 22:51

Quote:

Originally Posted by jason
Where can I get/How do I generate a template file?

You don't have to generate template files - they come with ISPConfig and are used to write the configuration files. You don't have to deal with them at all. You only need to work with the web interface, nothing else. :)


All times are GMT +2. The time now is 17:56.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.