HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   General (http://www.howtoforge.com/forums/forumdisplay.php?f=21)
-   -   make fails to run (cache.c:336/340) (http://www.howtoforge.com/forums/showthread.php?t=2520)

ollu 13th February 2006 23:14

make fails to run (cache.c:336/340)
 
1 Attachment(s)
When I try to run the make command I get the following errors:

cache.c:336: error: invalid lvalue in assignment
cache.c:340: error: invalid lvalue in assignment

I've attached the complete output file.

thanks in advance!

falko 14th February 2006 09:20

Please try to install MyDNS version 1.1.0 instead of 1.0.0.

ollu 14th February 2006 10:50

Ok, now the installation worked. Thanks!

I'm curious though, when I first started mydns it hanged, that is I didn't get back my promt. What's up eith the group/user nobody? This is my output:

root@bowie:/etc/init.d# mydns start
mydns: Extraneous command-line arguments ignored
mydns[5012]: error loading gid for group `nobody'
mydns[5012]: using gid 65534 from user `nobody'
mydns[5012]: mydns 1.1.0 started Tue Feb 14 10:28:29 2006 (listening on 3 addresses)
mydns[5012]: bowie up 2m20s (140s) 0 questions (0/s) NOERROR=0 SERVFAIL=0 NXDOMAIN=0 NOTIMP=0 REFUSED=0
mydns[5012]: interrupted
root@bowie:/etc/init.d# cd /
root@bowie:/# /etc/init.d/mydns stop
Stopping DNS server: mydns.
root@bowie:/# /etc/init.d/mydns start
Starting DNS server: mydnsmydns[5052]: error loading gid for group `nobody'
mydns[5052]: using gid 65534 from user `nobody'
.
root@bowie:/#


I'll continue the rest of the howto tonight. Thanks for your active interest!!

till 14th February 2006 10:59

Maybe you dont have a group nobody, on some linux systems the group is named nogroup instead.

I think it is ok that MyDNS uses the group of the nobody user instead, so dont worry :)

falko 14th February 2006 11:19

Quote:

Originally Posted by ollu
mydns[5012]: error loading gid for group `nobody'
mydns[5012]: using gid 65534 from user `nobody'

You must change the group in /etc/mydns.conf:

Code:

group = nogroup
This is described on page 1 of the MyDNS tutorial: http://www.howtoforge.com/mydns_name_server


All times are GMT +2. The time now is 17:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.