HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Virtual users... Ubuntu 8.04 - Problem after step 9 with Postfix (http://www.howtoforge.com/forums/showthread.php?t=24686)

jdrews 2nd July 2008 08:04

Virtual users... Ubuntu 8.04 - Problem after step 9 with Postfix - SOLVED
 
At the end of Step 9 in "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04 LTS).pdf", when directed to type netstat -tap, I do not see the Postfix (master)
listening on 25 or 10025. I get:

root@server1:/etc/postfix# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdo:10024 *:* LISTEN 4697/amavisd (maste
tcp 0 0 localhost.localdo:mysql *:* LISTEN 4771/mysqld
tcp 0 0 *:webmin *:* LISTEN 5426/perl
tcp 0 0 *:www *:* LISTEN 5403/apache2
tcp6 0 0 [::]:imaps [::]:* LISTEN 5221/couriertcpd
tcp6 0 0 [::]:pop3s [::]:* LISTEN 5255/couriertcpd
tcp6 0 0 [::]:pop3 [::]:* LISTEN 5235/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 5196/couriertcpd
tcp6 0 0 [::]:ssh [::]:* LISTEN 4662/sshd
tcp6 0 0 server1.ntexnw.com:ssh 192.168.0.200%8191:1541 ESTABLISHED 5434/sshd: administ



When testing with Telnet I get:

root@server1:/etc/postfix# telnet localhost 25
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
root@server1:/etc/postfix#

The computer is AMD 64X2 4800+ on an ECS 1600PM-M2 motherboard. The installation is per the pdf with
the exception that Webmin is also installed.

I have repeated this installation and always get the above results. As a newbie, I am stumped.
What should I try next to resolve this issue?

Thanks

falko 3rd July 2008 16:54

Any errors in /var/log/mail.log?

jdrews 3rd July 2008 21:31

Ubuntu 8.04 - Problem after step 9 with Postfix
 
Yes, I see:

"fatal: /etc/postfix/master.cf: line 84: bad transport type: smtp_data_done_timeout=1200"


Additional information:

I have determined that just before the end of step 9 where:

"Afterwards append the following lines to /etc/postfix/master.cf:
vi /etc/postfix/master.cf . . . ."

that doing this append causes the listener failure to occur.

I tried removing the line:
"-o smtp_data_done_timeout=1200", but the failure still occured.

Removing all of the appended lines and restarting Postfix results in the correct listener table except, of course, the 10025 line is not present.

jdrews

falko 4th July 2008 16:32

What's in your /etc/postfix/master.cf?

jdrews 4th July 2008 18:47

Ubuntu 8.04 - Problem after step 9 with Postfix
 
Here it is:

root@server1:/home/administrator# cat /etc/postfix/master.cf
#
# Postfix master process configuration file. For details on the format
# of the file, see the master(5) manual page (command: "man 5 master").
#
# Do not forget to execute "postfix reload" after editing this file.
#
# ================================================== ========================
# service type private unpriv chroot wakeup maxproc command + args
# (yes) (yes) (yes) (never) (100)
# ================================================== ========================
# Can change smtpd port from smtp (25) to 940:
smtp inet n - - - - smtpd
#940 inet n - - - - smtpd

#submission inet n - - - - smtpd
# -o smtpd_tls_security_level=encrypt
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
# -o milter_macro_daemon_name=ORIGINATING
#smtps inet n - - - - smtpd
# -o smtpd_tls_wrappermode=yes
# -o smtpd_sasl_auth_enable=yes
# -o smtpd_client_restrictions=permit_sasl_authenticate d,reject
# -o milter_macro_daemon_name=ORIGINATING
#628 inet n - - - - qmqpd
pickup fifo n - - 60 1 pickup
cleanup unix n - - - 0 cleanup
qmgr fifo n - n 300 1 qmgr
#qmgr fifo n - - 300 1 oqmgr
tlsmgr unix - - - 1000? 1 tlsmgr
rewrite unix - - - - - trivial-rewrite
bounce unix - - - - 0 bounce
defer unix - - - - 0 bounce
trace unix - - - - 0 bounce
verify unix - - - - 1 verify
flush unix n - - 1000? 0 flush
proxymap unix - - n - - proxymap
proxywrite unix - - n - 1 proxymap
smtp unix - - - - - smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay unix - - - - - smtp
-o smtp_fallback_relay=
# -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq unix n - - - - showq
error unix - - - - - error
retry unix - - - - - error
discard unix - - - - - discard
local unix - n n - - local
virtual unix - n n - - virtual
lmtp unix - - - - - lmtp
anvil unix - - - - 1 anvil
scache unix - - - - 1 scache
#
# ================================================== ==================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent. See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ================================================== ==================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop unix - n n - - pipe
flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp unix - n n - - pipe
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail unix - n n - - pipe
flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp unix - n n - - pipe
flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix - n n - 2 pipe
flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman unix - n n - - pipe
flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
${nexthop} ${user}

amavis unix - - - - 2 smtp
-o smtp_data_done_timeout=1200
-o smtp_send_xforward_command=yes
127.0.0.1:10025 inet n - - - - smtpd

-o content_filter=
-o local_recipient_maps=
-o relay_recipient_maps=
-o smtpd_restriction_classes=
-o smtpd_client_restrictions=
-o smtpd_helo_restrictions=
-o smtpd_sender_restrictions=
-o smtpd_recipient_restrictions=permit_mynetworks,rej ect
-o mynetworks=127.0.0.0/8
-o strict_rfc821_envelopes=yes
-o receive_override_options=no_unknown_recipient_chec ks,no_header_body_checks
-o smtpd_bind_address=127.0.0.1
root@server1:/home/administrator#

falko 5th July 2008 09:02

The problem is that you have an empty line after 127.0.0.1:10025 inet n - - - - smtpd...

Please try to make it look exactly as in the tutorial.

jdrews 5th July 2008 19:08

Ubuntu 8.04 - Problem after step 9 with Postfix - SOLVED
 
Falko,

I removed empty line after 127.0.0.1:10025 inet n - - - - smtpd and restarted Postfix, but still had the same error.

Following your admonition to carefully follow the tutorial, I examined the master.cf file more carefully and noticed that the continuation lines following "amavis unix - - - - 2 smtp" and "127.0.0.1:10025 inet n - - - - smtpd" did not include any whitespace at their beginnings; e.g. "-o content_filter=" instead of " -o content_filter=". This happened as I cut and pasted from the tutorial while in an ssh putty window on a Windows XP workstation. I reviewed the Man Pages for Postfix master.cf and verified that the whitespace must be at the beginning of continuation lines. After fixing these errors in master.cf, restarting Postfix and rerunning netstat -tap, all is working as expected. I consider this issue closed and will continue with installing my "Virtual Users and Domains . . . .8.04).

Thank you for your guidance and patience. I am an experienced MS Server administrator, but I am a very new ubuntu/linux newbie. I appreciate your help and tutorials very much.

jdrews


All times are GMT +2. The time now is 04:18.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.