HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   ISPConfig and Ruby (http://www.howtoforge.com/forums/showthread.php?t=24623)

antun 30th June 2008 07:40

ISPConfig and Ruby
 
I'm trying to enable my ISPConfig (on Ubuntu) to run Rails apps. I just updated ISPConfig to 2.2.7, and followed this HowTo:

http://www.howtoforge.com/apache2-mo...2.20-and-above

When I run the test, it doesn't work; I just see the Ruby source displayed.

Step 5 of the instructions says:
Quote:

If you enable Ruby for that web site, ISPConfig adds something like this to the web site's Apache vhost configuration:
How do I "enable Ruby" for a web site? I don't see any options in the ISPConfig panel.

Should I have the ruby executable installed? I just installed the mod_ruby module as described in the instructions above. I'm using Ubuntu 6.06.2 LTS.

Thanks for any help in advance!

-Antun

Hans 30th June 2008 08:28

On the basis tab of the website in ISPConfig you should see a checkbox "Ruby".

antun 30th June 2008 17:26

Hi Hans,

I don't see a "Ruby" checkbox on the basis tab.

I've verified that ISPConfig 2.2.7 is successfully installed, by going to Tools>Software Version.

Is there anything else I have to install or update as far as Apache is concerned?

Thanks,

Antun

till 30th June 2008 18:37

Ruby is not supported by ISPConfig 2.2.7. Please update to the latest release (2.2.23).

antun 30th June 2008 19:24

Hi Till,

Ah - silly me! I downloaded 2.2.23, but then inadvertently re-installed 2.2.7 (which I still had in my downloads directory from before)! I've installed 2.2.23 correctly now, and I do get the Ruby option on the basis tab. I've checked it for a site, but my test .rb script still doesn't work.

Do I need to do anything else? After checking the Ruby checkbox, and restarting Apache, I don't see anything about Ruby in the vhosts file here:

/etc/apache2/vhosts/Vhosts_ispconfig.conf

Should there be something there?

Thanks,

Antun

till 30th June 2008 19:27

Did you install mod_ruby first? Otherwise it will lead to an error when you enable ruby in ISPConfig and ISPConfig will use a copy of the last working version of the Vhosts_ispconfig.conf file, the one without ruby enabled.

antun 30th June 2008 19:31

Hi Till,

Yes, I had installed mod_ruby yesterday, using the following command:

apt-get install libapache2-mod-ruby

I did a phpinfo() to check whether it was installed, and mod_ruby is in the list of "Loaded Modules" under "apache2handler".

-Antun

till 30th June 2008 19:34

Please post the output of:

ls -la /etc/apache2/vhosts/

antun 30th June 2008 19:44

Hi Till,

Thanks for your time:

root@www:~/downloads/ispconfig# ls -la /etc/apache2/vhosts/
total 92
drwxr-xr-x 2 root root 4096 2008-06-30 10:32 .
drwxr-xr-x 9 root root 4096 2008-06-29 22:26 ..
-rw-r--r-- 1 root root 10915 2008-06-30 10:27 Vhosts_ispconfig.conf
-rw-r--r-- 1 root root 10977 2008-06-19 22:25 Vhosts_ispconfig.conf_19-06-08_22-25-31
-rw-r--r-- 1 root root 10975 2008-06-20 10:01 Vhosts_ispconfig.conf_20-06-08_10-01-31
-rw-r--r-- 1 root root 10975 2008-06-29 22:15 Vhosts_ispconfig.conf_29-06-08_22-15-55
-rw-r--r-- 1 root root 10975 2008-06-30 10:10 Vhosts_ispconfig.conf_30-06-08_10-10-36
-rw-r--r-- 1 root root 10933 2008-06-30 10:25 Vhosts_ispconfig.conf_30-06-08_10-25-50
-rw-r--r-- 1 root root 11273 2008-06-30 10:27 Vhosts_ispconfig.conf_30-06-08_10-27-34

Regards,

Antun

falko 1st July 2008 21:49

http://www.howtoforge.com/forums/showthread.php?t=7719


All times are GMT +2. The time now is 04:32.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.