HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Webmail instructions missing (http://www.howtoforge.com/forums/showthread.php?t=246)

bosei 13th August 2005 07:11

Webmail instructions missing
 
The Admin manual says you can use the update page to install uebimiau. i have tried anf it just comes up with various errors. Is there a simple way to install this last part or is there a way to use Squirrelmail?

Please help.

:o

bosei 13th August 2005 07:12

Quote:

Originally Posted by bosei
The Admin manual says you can use the update page to install uebimiau. i have tried anf it just comes up with various errors. Is there a simple way to install this last part or is there a way to use Squirrelmail?

Please help.

:o


apt-get install also fails to find package.

till 13th August 2005 11:13

Quote:

Originally Posted by bosei
The Admin manual says you can use the update page to install uebimiau. i have tried anf it just comes up with various errors.

If you dont post the errors here, i cant help you.

Quote:

Originally Posted by bosei
Is there a simple way to install this last part or is there a way to use Squirrelmail?

What is simple? Make a new site with PHP enabled, download the squirrelmail package from squirrelmail.org and follow the instructions that are inside the squirrelmail.tar.gz file.

falko 13th August 2005 14:54

Quote:

Originally Posted by bosei
The Admin manual says you can use the update page to install uebimiau. i have tried anf it just comes up with various errors. Is there a simple way to install this last part or is there a way to use Squirrelmail?

Please help.

:o

I guess you tried to install a tar.gz file you downloaded from the Uebimiau web site. This doesn't work! You have to take the webmail package (extension .pkg) from the ISPConfig website:
http://www.ispconfig.org/downloads/webmail.pkg

Those .pkg files are versions adjusted to ISPConfig! You cannot take other files!

bosei 14th August 2005 04:13

Webmail instructions missing
 
Thanks guys.

I was installing from the .pkg file downloaded from ISPConfig site but I was attempting the install remotely from another workstation. As soon as i tried it from the subject server... it worked like a charm.

It seems I have SquirrelMail installed as well. Will there be any clashes or does it just mean choice for my clients?

I have a few more questions so i hope y'all don't mind too much as you have helped me install all of this in days rather than weeks/months. :D
  1. just tried installing oscommerce and it errored with "FATAL ERROR: register_globals is disabled in php.ini, please enable it!" Can this be fixed or will it hard my ispconfig install and if no then can anyone recommend another shop/basket?
  2. I have the subject server behind a seperate firewall which allows me to port-forward so everything can now be seen from the outside except Postfix allows receiving of mails but not sending. the internal IP is 192.168.1.5 (DMZ local address), pointing to an external address (say 173.36.29.81) which is on the wan side of the firewall. I think postfix does not allow clients on a different subnet to send mail although they can receive. i have not made any changes to postfix configs etc what is in the tutorial best ever.... SuSE 9.3. Can anyone help with this one?

Finally, a big thank you to Falko... your guide is fantastic and has saved me a lot of time after attempting several other tutorials on the postfix homepage. May I suggest you put a link there as I for one will be evangelising about ISPConfig to anyone who will listen.


Many many thanks
:cool:

till 14th August 2005 11:30

Quote:

Originally Posted by bosei
Thanks guys.

I was installing from the .pkg file downloaded from ISPConfig site but I was attempting the install remotely from another workstation. As soon as i tried it from the subject server... it worked like a charm.

It seems I have SquirrelMail installed as well. Will there be any clashes or does it just mean choice for my clients?

It's up to your clients, they can use the webmailer they prefer.


Quote:

Originally Posted by bosei
I have a few more questions so i hope y'all don't mind too much as you have helped me install all of this in days rather than weeks/months. :D
  1. just tried installing oscommerce and it errored with "FATAL ERROR: register_globals is disabled in php.ini, please enable it!" Can this be fixed or will it hard my ispconfig install and if no then can anyone recommend another shop/basket?

  1. You have to set
    Code:

    register_globals = On
    in your php.ini


    Quote:

    Originally Posted by bosei
  2. I have the subject server behind a seperate firewall which allows me to port-forward so everything can now be seen from the outside except Postfix allows receiving of mails but not sending. the internal IP is 192.168.1.5 (DMZ local address), pointing to an external address (say 173.36.29.81) which is on the wan side of the firewall. I think postfix does not allow clients on a different subnet to send mail although they can receive. i have not made any changes to postfix configs etc what is in the tutorial best ever.... SuSE 9.3. Can anyone help with this one?

Did you get any error messages in the mail.log when you try to send mails?

falko 14th August 2005 15:13

Quote:

Originally Posted by bosei
just tried installing oscommerce and it errored with "FATAL ERROR: register_globals is disabled in php.ini, please enable it!" Can this be fixed or will it hard my ispconfig install and if no then can anyone recommend another shop/basket?

You can also enter
Code:

php_admin_flag register_globals on
in the Apache Directives field for this web site in ISPConfig.

bosei 16th August 2005 00:15

Quote:

Originally Posted by till
It's up to your clients, they can use the webmailer they prefer.




You have to set
Code:

register_globals = On
in your php.ini




Did you get any error messages in the mail.log when you try to send mails?


Quote:

Originally Posted by falko
You can also enter
Code:

php_admin_flag register_globals on
in the Apache Directives field for this web site in ISPConfig.

Thanks for the rapid replies guys. I will try all this tomorrow night as I have now been up 3 days and I gotta go earn a crust in the morning. :(

Just one other thing i would like to say.... You guys are a total credit to your product and the forum. :cool:

bosei 22nd December 2005 17:28

Quote:

Originally Posted by bosei
Thanks for the rapid replies guys. I will try all this tomorrow night as I have now been up 3 days and I gotta go earn a crust in the morning. :(

Just one other thing i would like to say.... You guys are a total credit to your product and the forum. :cool:


Worked great. resolved


All times are GMT +2. The time now is 10:09.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.