HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Can't send or receive email! (http://www.howtoforge.com/forums/showthread.php?t=24596)

sergio.morales 29th June 2008 05:42

Can't send or receive email!
 
Hey folks! Total newbie here. I installed ISPconfig as per the instructions in the Fedora9 Perfect server and all is well. However, I can't seem to send or receive email from the new client I made. Can someone help a newbie here and tell me where I should start looking?

Pleas help!!

sERGE

Hans 29th June 2008 11:12

Did you enable the Maildir format within ISPConfig under Management > Server > settings > Email?

Please have a look within your mail logfile /var/log/mail.log.
Use the command tail -f mail.log to follow what's happening. CTRL+C to quit.

sergio.morales 30th June 2008 01:26

Well I can send email now . . .
 
Well, I can now send email, but receiving is still a no-go. I have indeed enabled the Maildir in ISPconfig ( I had it enabled already, but I disabled it and reenabled 5 minutes later). I don't really know what to look for in my maillog, so I'll include a snippit to see if anyone can see what it is I'm doing wrong . . .

Jun 29 18:30:01 email-beststylesusa sendmail[9432]: m5TMU1Au009432: from=root, size=173, class=0, nrcpts=1, msgid=<200806292230.m5TMU1Au009432@email-beststylesusa.com>, relay=root@localhost
Jun 29 18:30:01 email-beststylesusa postfix/smtpd[9433]: connect from localhost.localdomain[127.0.0.1]
Jun 29 18:30:01 email-beststylesusa postfix/smtpd[9433]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Jun 29 18:30:01 email-beststylesusa sendmail[9432]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jun 29 18:30:01 email-beststylesusa postfix/smtpd[9433]: Anonymous TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jun 29 18:30:01 email-beststylesusa postfix/smtpd[9433]: 431A03CA2CD: client=localhost.localdomain[127.0.0.1], sasl_sender=root@email-beststylesusa.com
Jun 29 18:30:01 email-beststylesusa postfix/cleanup[9436]: 431A03CA2CD: message-id=<200806292230.m5TMU1Au009432@email-beststylesusa.com>
Jun 29 18:30:01 email-beststylesusa postfix/qmgr[26035]: 431A03CA2CD: from=<root@email-beststylesusa.com>, size=797, nrcpt=1 (queue active)
Jun 29 18:30:01 email-beststylesusa sendmail[9432]: m5TMU1Au009432: to=root@localhost, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30173, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 431A03CA2CD)
Jun 29 18:30:01 email-beststylesusa postfix/smtpd[9433]: disconnect from localhost.localdomain[127.0.0.1]
Jun 29 18:30:01 email-beststylesusa postfix/local[9437]: 431A03CA2CD: to=<root@email-beststylesusa.com>, relay=local, delay=0.07, delays=0.05/0.01/0/0.01, dsn=2.0.0, status=sent (delivered to maildir)
Jun 29 18:30:01 email-beststylesusa postfix/qmgr[26035]: 431A03CA2CD: removed
Jun 29 19:00:01 email-beststylesusa sendmail[9806]: m5TN01qf009806: from=root, size=173, class=0, nrcpts=1, msgid=<200806292300.m5TN01qf009806@email-beststylesusa.com>, relay=root@localhost
Jun 29 19:00:01 email-beststylesusa postfix/smtpd[9807]: connect from localhost.localdomain[127.0.0.1]
Jun 29 19:00:01 email-beststylesusa postfix/smtpd[9807]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Jun 29 19:00:01 email-beststylesusa postfix/smtpd[9807]: Anonymous TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jun 29 19:00:01 email-beststylesusa sendmail[9806]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jun 29 19:00:01 email-beststylesusa postfix/smtpd[9807]: 6A4083CA2CD: client=localhost.localdomain[127.0.0.1], sasl_sender=root@email-beststylesusa.com
Jun 29 19:00:01 email-beststylesusa postfix/cleanup[9810]: 6A4083CA2CD: message-id=<200806292300.m5TN01qf009806@email-beststylesusa.com>
Jun 29 19:00:01 email-beststylesusa postfix/qmgr[26035]: 6A4083CA2CD: from=<root@email-beststylesusa.com>, size=797, nrcpt=1 (queue active)
Jun 29 19:00:01 email-beststylesusa sendmail[9806]: m5TN01qf009806: to=root@localhost, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30173, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 6A4083CA2CD)
Jun 29 19:00:01 email-beststylesusa postfix/local[9811]: 6A4083CA2CD: to=<root@email-beststylesusa.com>, relay=local, delay=0.08, delays=0.05/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to maildir)
Jun 29 19:00:01 email-beststylesusa postfix/qmgr[26035]: 6A4083CA2CD: removed
Jun 29 19:00:01 email-beststylesusa postfix/smtpd[9807]: disconnect from localhost.localdomain[127.0.0.1]
[root@email-beststylesusa log]# vi maillog

falko 30th June 2008 15:13

Please make sure that the MX record of your domain is pointint to the right server. You can check that with
Code:

dig mx yourdomain.com

sergio.morales 1st July 2008 03:53

Still confused and maybe MORE broken
 
This is the response to the dig mx mydomain.com: ; <<>> DiG 9.5.0rc1

Now here's the problem: I was looking at my /etc/hosts and I saw 2 things that seemed odd. First, the localhost entry had localhost twice, so I deleted one of the instances, and I deleted my alias for email-beststylesusa.com (which was just plain email-beststylesusa) and I rebooted. I can't seem to get to the web GUI for ISPconfig, despite the fact that it says it's running! Email is shot too because I can't send or receive. SO, how badly did I just shoot myself in the foot? Is this recoverable? I set the entries back to their original state, but it still wont work!!

HELP!

sERGE
<<>> mx email-beststylesusa.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6317
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 3, ADDITIONAL: 3

;; QUESTION SECTION:
;email-beststylesusa.com. IN MX

;; ANSWER SECTION:
email-beststylesusa.com. 21600 IN MX 10 68.167.129.3.email-beststylesusa.com.
email-beststylesusa.com. 21600 IN MX 100 68.167.129.3.email-beststylesusa.com.
email-beststylesusa.com. 21600 IN MX 110 68.167.129.3.email-beststylesusa.com.

;; AUTHORITY SECTION:
email-beststylesusa.com. 21600 IN NS ns2.meganameservers.com.
email-beststylesusa.com. 21600 IN NS ns3.meganameservers.com.
email-beststylesusa.com. 21600 IN NS ns1.meganameservers.com.

;; ADDITIONAL SECTION:
ns1.meganameservers.com. 3971 IN A 216.251.32.100
ns2.meganameservers.com. 17654 IN A 216.251.32.101
ns3.meganameservers.com. 17499 IN A 64.29.144.65

;; Query time: 44 msec
;; SERVER: 64.105.124.154#53(64.105.124.154)
;; WHEN: Mon Jun 30 21:49:07 2008
;; MSG SIZE rcvd: 220

till 1st July 2008 09:02

One thing first, MX records are not stored in /etc/hosts. They are set in the config files of the BIND name server.

Please post the output of:

netstat -tap

and:

iptables -L

sergio.morales 1st July 2008 14:31

Netstat and IPtables output
 
[root@email-beststylesusa ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:57769 *:* LISTEN 1914/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2376/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1895/rpcbind
tcp 0 0 *:81 *:* LISTEN 2735/ispconfig_http
tcp 0 0 email-beststylesusa.:domain *:* LISTEN 2864/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2864/named
tcp 0 0 *:ssh *:* LISTEN 2258/sshd
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2625/cupsd
tcp 0 0 *:smtp *:* LISTEN 5452/master
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2864/named
tcp 0 0 localhost.lo:x11-ssh-offset *:* LISTEN 13409/0
tcp 0 960 email-beststylesusa.com:ssh cpe-98-15-243-177.hvc:55274 ESTABLISHED 13406/sshd: moralse
tcp 0 0 *:imaps *:* LISTEN 2399/dovecot
tcp 0 0 *:pop3s *:* LISTEN 2399/dovecot
tcp 0 0 *:pop3 *:* LISTEN 2399/dovecot
tcp 0 0 *:imap *:* LISTEN 2399/dovecot
tcp 0 0 *:http *:* LISTEN 2765/httpd
tcp 0 0 *:ssh *:* LISTEN 2258/sshd
tcp 0 0 *:smtp *:* LISTEN 5452/master
tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 2864/named
tcp 0 0 localhost6.l:x11-ssh-offset *:* LISTEN 13409/0
tcp 0 0 *:https *:* LISTEN 2765/httpd
[root@email-beststylesusa ~]#


IPTABLES -L

[root@email-beststylesusa ~]# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere state RELATED,ESTABLISHED
ACCEPT icmp -- anywhere anywhere
ACCEPT all -- anywhere anywhere
ACCEPT tcp -- anywhere anywhere state NEW tcp dpt:ssh
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target prot opt source destination
REJECT all -- anywhere anywhere reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
[root@email-beststylesusa ~]#

falko 2nd July 2008 12:17

Quote:

Originally Posted by sergio.morales (Post 133554)
email-beststylesusa.com. 21600 IN MX 10 68.167.129.3.email-beststylesusa.com.

IS this the correct mail server? Does 68.167.129.3.email-beststylesusa.com point to your server?

Does it work when you switch off the firewall?

sergio.morales 2nd July 2008 15:08

whoa . . . that's wrong
 
Hey Falko. Thanks for the help. The record is not right. Is it getting that from my ISP, or from the ISPconfig DNS?

Thanks!

sERGE

falko 3rd July 2008 16:51

It's coming from these two nameservers:

Code:

server1:~# dig ns email-beststylesusa.com

; <<>> DiG 9.3.4 <<>> ns email-beststylesusa.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9090
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;email-beststylesusa.com.      IN      NS

;; ANSWER SECTION:
email-beststylesusa.com. 172800 IN      NS      ns1.covad.net.
email-beststylesusa.com. 172800 IN      NS      ns2.covad.net.

;; Query time: 91 msec
;; SERVER: 213.191.92.84#53(213.191.92.84)
;; WHEN: Thu Jul  3 16:51:00 2008
;; MSG SIZE  rcvd: 86

server1:~#



All times are GMT +2. The time now is 11:20.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.