HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   HOWTO: Unlock A LUKS Encrypted Root Partition Via SSH On Ubuntu (http://www.howtoforge.com/forums/showthread.php?t=24522)

peter7 26th June 2008 17:00

HOWTO: Unlock A LUKS Encrypted Root Partition Via SSH On Ubuntu
 
I am trying to apply the Howto indicated in the title to a fully encrypted (by alternative
install) Kubuntu 8.04. I can login over ssh after the boot but the
"unlock" command is just hanging there with the message:

Code:

Setting up cryptographic volume sda2_crypt (based on /dev/disk/by-uuid/...
It never prompts for the pass phrase or does anything.

I was wondering if anybody has some idea how to proceed. I tried to do
manually what unlock does with the same result.

sjau 26th June 2008 20:22

you do have a fully encrypted system?

peter7 26th June 2008 23:02

Yes I do, except the /boot partition of course.

sjau 27th June 2008 08:30

Post your /etc/initramfs-tools/scripts/local-top/cryptroot script

peter7 27th June 2008 17:56

Quote:

Originally Posted by sjau (Post 132931)
Post your /etc/initramfs-tools/scripts/local-top/cryptroot script

This directory is empty.

If you mean the file /scripts/local-top/cryptroot in the netboot initrd image then it is the same as what is in the original initrd. Which in turn comes from /usr/share/initramfs-tools/scripts/local-top/cryptroot unmodified. These files are part of the cryptsetup package and are the same over all ubuntu based distros. My cryptsetup is version 2:1.0.5-2ubuntu12

What I noticed that the prompt asking for the pass phrase showed up on the console instead of in my ssh session but took no input.

sjau 27th June 2008 20:17

are you using LVM?

peter7 27th June 2008 20:37

Quote:

Originally Posted by sjau (Post 133073)
are you using LVM?

Yes, but the encryption is on the underlying (single) physical partition.
The failed netboot procedure does not get to the lvm phase at all.

sjau 27th June 2008 20:44

there has been an issue with kernel and lvm... I don't recall the exact specifics right now....

sjau 27th June 2008 21:30

I just re-set it up according to my howto in a vm... it works great... the only problem I had (in the beginning) that I did copy a single/recovery user grub entry.... once I realized that it worked again...

So, try it on your computer in a vmware or so with a non-lvm install....


All times are GMT +2. The time now is 01:14.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.