HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Adding a Physical NIC to Xen host (http://www.howtoforge.com/forums/showthread.php?t=24513)

atjensen11 26th June 2008 03:29

Adding a Physical NIC to Xen host
 
Hello,

I have just installed Xen and configured a virtual machine for the first time. I followed the following How To:

http://www.howtoforge.com/ubuntu-8.0...u-repositories

When I did the initial install and configuration of the VM, the physical machine only had one NIC installed. I now want to install a second physical NIC in the machine and eventually have the VM utilize the second NIC.

After installing the NIC, I logged onto the Dom0 machine. I then modified /etc/network/interfaces.

After issuing the ifconfig command, I failed to see the second interface.

My guess is that my approach is wrong since the Dom0 is really a VM as well. So how do I go about adding the second NIC and configuring the existing VM's to use it?

c4rdinal 26th June 2008 11:07

You want to try this link

Using multiple network cards in XEN 3.0
http://www.debian-administration.org/articles/470

HTH

atjensen11 28th June 2008 01:51

I had to read this article three times before it started making sense to me. I don't know that I fully understand it yet, but I think I am getting there. It appears as though you are creating a bridge to each physical NIC in the machine, then forcing each VM to use a specific physical NIC.

However, one thing that is somewhat confusing to me is that many articles dealing with Xen reference xenbr0. I never see that on my machine. Here is the results of my brctl show command:

Code:

bridge name    bridge id              STP enabled    interfaces
eth0            8000.00123f3b119c      no              peth0
                                                        vif1.0

It appears to me that my bridge name is eth0. Is that correct? I think that has been confusing me.

Lastly, it appears that I could build my machines and "move" them to physical NIC's when I have them. Right now, I only have two NIC's but would like a third. It would appear that the same steps apply. I was under the assumption the NIC's would need to be present before creating the VM.

Thanks.

atjensen11 21st July 2008 17:57

Okay, so I managed to get my two NICs working and configured on my Dom0 before creating the my-network-script as suggested on the URL.

This is the second time actually going through the setup. In both instances, the machine is unreachable via SSH (or any protocol for that matter) after implementing the script.

I can login at the terminal. Upon watching the messages on the screen, I see two related to my NICs. They read:

Code:

Waiting for peth0 to negotiate link...
Ignoring unknown interface xenbr0=xenbr0.
[...]
Waiting for peth1 to negotiate link.
Ignoring unknown interface xenbr1=xenbr1.

If I login and type the ifconfig command, only the lo, peth0, and peth1 interfaces are shown. eth0 and eth1 are missing.

Any suggestions?

atjensen11 7th August 2008 18:29

I wanted to say that I did get it to work. The bridged names are now called the same as the physical names (eth0 and eth1). I had to read all the comments on the list of the web site above in order to find my solution. But it worked none the less.


All times are GMT +2. The time now is 02:36.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.