HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   turn off "PHP Scripts" problem after updated php (http://www.howtoforge.com/forums/showthread.php?t=2402)

k-dev4edv 6th February 2006 16:18

turn off "PHP Scripts" problem after updated php
 
Hi, after I had updated the php version on my debian 3.1 server (from 5.0.5 to 5.1.2), apache ignores my settings for php in the "ISP Manager"-Tool.
When I turn off "PHP Scripts", the scripts are still executed, only the "PHP Safe Mode"-setting works correctly. I tried to reinstall ISPConfig with "./setup", but the problem still occurs. :( PHP is now globally activated for all websites on my server. Is there a way to get back the control over my apache php settings by ISPConfig, e.g. delete apache config before reinstall ISPConfig, ...? :confused:

falko 6th February 2006 18:18

Quote:

Originally Posted by k-dev4edv
PHP is now globally activated for all websites on my server.

If PHP is globally enabled, it will work, no matter what you specify in ISPConfig.
You must disable PHP in your Apache configuration, as outlined in the "Perfect Setup" guides on HowtoForge.

k-dev4edv 7th February 2006 09:34

That's it
 
Thank you very much. :D
I forgot to look into the file /etc/apache2/mods-enabled/php5.1.conf
Shame on me. :p


All times are GMT +2. The time now is 09:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.