HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   The Perfect Setup... IMAP help??? (http://www.howtoforge.com/forums/showthread.php?t=24)

leon 22nd April 2005 12:56

The Perfect Setup... IMAP help???
 
I have just completed a third installation of SuSE 9.2 following the SuSE Perfect Setup document to the letter. Now, for the third time in a row, I can get everything to work accept IMAP. For some reason (which I am having some trouble with) I can't connect an email client with IMAP to the server. I keep getting a bad username or password response. I am 100% sure that the username and password combination is good but still it will not work.

Could you possibly give me an idea where I should look to solve this problem??

Leon

falko 22nd April 2005 19:56

When you try to connect to your SuSE system using IMAP, do you see corresponding log entries in /var/log/mail? If there are no messages at all that indicate that you are trying to connect then it might be a firewall issue.

leon 23rd April 2005 20:08

The error messages that I am getting in /var/log/mail are:

Code:

Apr 20 22:16:00 webmail imapd: Connection, ip=[::ffff:192.168.10.107]
Apr 20 22:16:00 webmail imapd: chdir Maildir: No such file or directory

Should I have created a Mail directory somewhere??

Leon

falko 23rd April 2005 20:39

Code:

Should I have created a Mail directory somewhere??
Yes, you must create a directory called Maildir in the user's home directory. It must belong to that user and have the privileges 700. You might also have to create the directories cur, new and tmp in the Maildir directory, with the same owner and permissions as Maildir itself.

leon 23rd April 2005 21:03

That was it!! Thanx a million!!

It's working like a charm now.

Leon

matrixn 6th August 2008 14:34

where i have to create the maildir directory? ... i`m on suse 11.0 with an ispconfig 2.2.24 and roundcube.. and i`m not able to login.

mail.info :

Code:

ns:/ # tail -f /var/log/mail.info
Aug  6 14:26:00 ns postfix/master[18317]: daemon started -- version 2.5.1, configuration /etc/postfix
Aug  6 14:27:13 ns imapd: chdir Maildir: No such file or directory
Aug  6 14:27:30 ns imapd: LOGIN FAILED, user=web6_admin, ip=[::ffff:127.0.0.1]
Aug  6 14:28:29 ns postfix/master[18317]: terminating on signal 15
Aug  6 14:28:30 ns postfix/postfix-script[18487]: starting the Postfix mail system
Aug  6 14:28:30 ns postfix/master[18488]: daemon started -- version 2.5.1, configuration /etc/postfix
Aug  6 14:28:40 ns imapd: chdir Maildir: No such file or directory
Aug  6 14:28:52 ns imapd: LOGIN FAILED, user=web6_admin, ip=[::ffff:127.0.0.1]
Aug  6 14:29:03 ns imapd: LOGIN FAILED, user=admin, ip=[::ffff:127.0.0.1]
Aug  6 14:29:20 ns imapd: chdir Maildir: No such file or directory
Aug  6 14:30:09 ns imapd: chdir Maildir: No such file or directory


falko 7th August 2008 13:52

Please send an email to that account. The Maildir gets created automatically once the first email arrives.

matrixn 7th August 2008 17:17

sorry.. i have fixed.. i forgot to check the mailbox option in ispconfig :(... now it works...

thanks for your reply...


All times are GMT +2. The time now is 19:23.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.