HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1 (http://www.howtoforge.com/forums/showthread.php?t=23700)

bup413 28th May 2008 16:46

Mail Server Setup With Exim, MySQL, Cyrus-Imapd, Horde Webmail On Centos 5.1
 
I have been banging my head for days and think I have finally narrowed things down. Following the HowTo listed in the title everything appeared to be going fine until I tried to login to Horde. I am down to this:
if I login to horde with user test_user@domain.net and watch the logs I see it is not passing the domain.net through to authenticate. I then went into MySQL and removed domain.net from that user. It now authenticates fine, however when trying to send an email I get the following error: "There was an error sending your message: Validation failed for: test_user@.SYNTAX-ERROR"
Honestly there is only one domain being used and always will be that way I would just assume users not have to put in the domain.net. Is there a way to knock out both problems at once?

topdog 29th May 2008 20:23

You should be able to authenticate with the full email address, the domain part is passed as the realm to the auth process.

bup413 29th May 2008 22:56

That was my thinking
 
That is what I thought, however when watching the logs is is parsing the complete email and tossing the domain. The realm comes through ' '

-A

topdog 30th May 2008 14:22

are you running saslauthd with the -r option ?

bup413 30th May 2008 14:55

I added the -r flag in /etc/sysconfig/saslauthd and tried again.
Here is the tail from the log file.

saslauthd[31401]: do_auth : auth failure: [user=test_user] [service=imap] [realm=] [mech=pam] [reason=PAM auth error]

topdog 30th May 2008 15:12

I had this exact issue when i wrote the tutorial, problem is i dont remember how i fixed i thought it was the -r flag but it seems not to be, do u have a default domain in your imapd.conf file ?

topdog 30th May 2008 15:20

Okay to drill this down, can you login to horde but cannot login to imp ? or you cannot login at all ?

bup413 30th May 2008 15:52

If I remove the domain from the users name in the horde_users SQL table it works. Then of course horde will not send mail because it doesn't have the domain set, so when I compose email it comes up but when you click send it fails. Watching the logs I can't get saslauthd to pass the realm.

topdog 30th May 2008 17:18

Okay with the full domain in the database can you login to horde ? but not imp or can you not login at all and did you restart saslauthd after you added the -r option ?

bup413 30th May 2008 20:34

It is logging into Horde but not imp


All times are GMT +2. The time now is 04:47.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.