HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   HOWTO-Related Questions (http://www.howtoforge.com/forums/forumdisplay.php?f=2)
-   -   I moved munin, now i'm screwed (http://www.howtoforge.com/forums/showthread.php?t=23498)

jdkullmann 21st May 2008 02:31

I moved munin, now i'm screwed
 
I installed munin as per the howto - worked great as usual (this is on Debian Etch setup as per howto).

As my 'real' web root was somewhere else (/var/www/webroot) I moved the munin dir from /var/www to /var/www/webroot. Munin broke. So I did
apt-get remove munin
apt-get remove munin-node
dpkg --purge munin
and I also removed other munin files i found, by hand

Now no matter what I do I cannot reinstall munin. apt-get install munin (and nunin-node) fails with error

....
Initializing new plugins../var/lib/dpkg/info/munin-node.postinst: line 27: munin-node-configure: command not found
done.
Munin-Node appears to be uninstalled.
invoke-rc.d: initscript munin-node, action "start" failed.
.....

i dont get it. I'm installing munin - why am I getting uninstalled errors? I've tried googling and looking at archives but I can't figure out how to reinstall.

i'm moving my web root back to /var/www and just want to get munin working again.

HELP!

jdkullmann 21st May 2008 02:41

Let me add that I believe it's because I manually removed files with munin in their name that is causing my problems. However, i didn't think the standard debian install would include munin files. I hope not.

apt-get install munin-node currently gets this error:
...
Setting up munin-node (1.2.5-1) ...
Initializing new plugins../var/lib/dpkg/info/munin-node.postinst: line 27: munin-node-configure: command not found
done.
...

So maybe what I'm asking is how do I get munin files that are not part of the munin pkgs reinstalled (I guess there must be some).

thanks

falko 21st May 2008 14:15

Remove munin-node like this:
Code:

apt-get remove --purge munin-node
Then install it again.
Then make sure you use the right directory as htmldir in /etc/munin/munin.conf, and that you chown that directory to munin:munin (see http://www.howtoforge.com/server_mon...it_debian_etch ).

jdkullmann 21st May 2008 15:10

OK I did that. htmldir (and everything) left stock. perms on /var/www/munin

drwxr-xr-x 3 munin munin 4096 2008-05-20 20:30 /var/www/munin

When i access myserver.com/munin I only see this now

localdomain
localhost.localdomain :: [ Disk Network Processes System ]

and none of the graphs that are displayed as I click around are ever updated.

falko 22nd May 2008 12:03

Any errors in your logs?

jdkullmann 22nd May 2008 14:00

There are two, one of which I can't figure out how to fix. This one I think will be fixed by rebooting which I will do now

2008/05/22-07:10:01 CONNECT TCP Peer: "127.0.0.1:52094" Local: "127.0.0.1:4949"
find: WARNING: Hard link count is wrong for /proc: this may be a bug in your filesystem driver. Automatically turning on find's -noleaf option.
Earlier results may have failed to include directories that should have been searched.


And this one I don't know how to fix - I've poked around but all the munin files here look just like the ones on another system of mine that is working. Here's the error

May 22 06:30:04 [28521] - Unable to update localdomain -> localhost.localdomain -> exim_mailqueue -> mails: No such field (no "label" field defi
ned when running plugin with "config").

falko 23rd May 2008 12:20

Are you using Exim or Postfix?

jdkullmann 23rd May 2008 14:41

I installed via your most excellent Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch), so, I'm using Postfix.

Hmm, so why is this suddenly complaining about exim?

This was working great until I moved /var/www/munin to my (old,since removed) /var/www/webroot/ , then i apt-get --purge removed munin and reinstalled (back to /var/www). Since then only those 4 items show up on the munin web page whereas before about 15 did

Thanks for helping

jdkullmann 24th May 2008 00:22

So, trying to start over again. I did this

sudo apt-get remove --purge munin
Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
munin*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0B of archives.
After unpacking 1020kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 33786 files and directories currently installed.)
Removing munin ...
Purging configuration files for munin ...
The generated web site or accumulated data won't be removed.
dpkg - warning: while removing munin, directory `/etc/munin' not empty so not removed.
dpkg - warning: while removing munin, directory `/var/run/munin' not empty so not removed.
dpkg - warning: while removing munin, directory `/var/www/munin' not empty so not removed.

And it didn't remove everything - according to the warnings. Last time I went and removed all that by hand and I think that's how I got into trouble the first time.

What do I do next to _really_ remove munin so I can reinstall it fresh and have it 'just work' like it did the first time?

Thanks

falko 24th May 2008 12:41

Quote:

Originally Posted by jdkullmann
dpkg - warning: while removing munin, directory `/etc/munin' not empty so not removed.
dpkg - warning: while removing munin, directory `/var/run/munin' not empty so not removed.
dpkg - warning: while removing munin, directory `/var/www/munin' not empty so not removed.

I'd remove these directories manually and install munin again. If that doesn't help, then I don't know... :(


All times are GMT +2. The time now is 11:27.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.