HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Mysql (http://www.howtoforge.com/forums/showthread.php?t=230)

ejs 10th August 2005 12:19

Mysql
 
what is causing this error? When i do the install it creates the mysql db but it is blank. I have tried to reinstall. I deleted the db and the isp file in the root before the reinstall. As per your instructions on another thread i did not put in the www and used the ip address for the rest of the domain name.


########## INSTALLATION ##########

Preparing files. Please wait a moment...
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
Please enter your MySQL user:root
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig): db_ispconfig
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):xxx.xxx.xxx.xxx
OK
Please enter the host name (e.g. www):
Please enter the domain (e.g. xyz.de):xxx.xxx.xxx.xxx
OK
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 2

Connected successfully to MySQL server
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
Restarting some services...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!FreshClam is already running!
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

[root@ns1 install_ispconfig]#

till 10th August 2005 12:30

Quote:

Originally Posted by ejs
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Reinstall ISPConfig, when you are asked for mySQL username and password provide a valid username and password that are allowed to connect to ISPConvig via a network connection from localhost.

ejs 11th August 2005 09:21

same responce
 
Ok i added a new user in mysql with all the rights you can give a user on the localhost. got the same responce? It is creating the data base but it is empty. what can i try next? Also i can not use the uninstall comand because of the issue. So i been deleting the isp file in the root folder. Is that enough to get rid of the program for reinstall? Also been deleting the db shell it creates in Mysql.


########## INSTALLATION ##########

Preparing files. Please wait a moment...
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
Please enter your MySQL user:ej
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig):db_ispconfig
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):xxx.xxx.xxx.xxx
OK
Please enter the host name (e.g. www):
Please enter the domain (e.g. xyz.de):xxx.xxx.xxx.xxx
OK
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 2

Connected successfully to MySQL server
ERROR 1045 (28000): Access denied for user 'ej'@'localhost' (using password: YES)
Restarting some services...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!FreshClam is already running!
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

falko 11th August 2005 11:06

Are you sure you used the right MySQL password for that user?

Can you post the output of
Code:

netstat -tap
here?

ejs 11th August 2005 17:24

Yes i am putting in the right password for root and the other account i created.



[root@ns1 ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 2204/xinetd
tcp 0 0 *:32769 *:* LISTEN 1849/rpc.statd
tcp 0 0 *:pop3s *:* LISTEN 2204/xinetd
tcp 0 0 *:mysql *:* LISTEN 21760/mysqld
tcp 0 0 *:pop3 *:* LISTEN 2204/xinetd
tcp 0 0 *:imap *:* LISTEN 2204/xinetd
tcp 0 0 *:sunrpc *:* LISTEN 1831/portmap
tcp 0 0 *:10000 *:* LISTEN 2555/perl
tcp 0 0 *:81 *:* LISTEN 28291/ispconfig_htt
tcp 0 0 adsl-068-213-093-013:domain *:* LISTEN 1805/named
tcp 0 0 *:ftp *:* LISTEN 4820/proftpd: (acce
tcp 0 0 adsl-xxx.xxx.xxx.xxx:domain *:* LISTEN 1805/named
tcp 0 0 adsl-xxx.xxx.xxx.xxx:domain *:* LISTEN 1805/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 1805/named
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2160/cupsd
tcp 0 0 localhost.localdomain:5335 *:* LISTEN 2142/mDNSResponder
tcp 0 0 *:smtp *:* LISTEN 4787/master
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 1805/named
tcp 0 16 adsl-xxx.xxx.xxx.xxx.s:pop3 206-216-114-243.colo.:31248 ESTABLISHED 27875/ipop3d
tcp 0 0 adsl-xxx.xxx.xxx.xxx.s:smtp mail3.ProductChoicePan:5249 TIME_WAIT -
tcp 0 0 *:http *:* LISTEN 2393/httpd
tcp 0 0 *:ssh *:* LISTEN 2195/sshd
tcp 0 0 *:8090 *:* LISTEN 2393/httpd
tcp 0 0 *:https *:* LISTEN 2393/httpd
tcp 0 0 adsl-xxx.xxx.xxx.xxx.si:ssh adsl-xxx.xxx.xxx.xxx.s:4771 ESTABLISHED 27882/1

ejs 12th August 2005 08:01

Ok
After some more testing i come to notice a few things. I reloaded the system and this time i did not do any updates. Also i noticed that the password for the the mysql does not like symbols like # $ @ *.

After i reloaded again and set the password for mysql in alfha only everything is working so far.


All times are GMT +2. The time now is 07:19.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.