HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Error installing ISPConfig on debian (http://www.howtoforge.com/forums/showthread.php?t=22651)

omniware 23rd April 2008 16:50

Error installing ISPConfig on debian
 
I'm installing a ISPConfig on a fresh lenny debian server.

I'm done all steps on the perfect debian etch setup (I think is very similar as Lenny). Tha's perfect.

Later I'm donwloaded ISPConfig-2.2.23.tar.gz, I unpacked it and I do ./setup
the process work fine just it get to make the mysql database.

The setup program create the database db_ispconfig. It fails an report that
Quote:

Please select the protocol (http or https (SSL encryption)) to use to access the
ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 1

Connected successfully to MySQL server
sh: -c: line 0: syntax error near unexpected token `('
sh: -c: line 0: `mysql -h mipc.domain.tld -u root -p mypassword db_ispconfig < db_ispconfig.sql'
Restarting some services...
Stopping Postfix Mail Transport Agent: postfix.
Starting Postfix Mail Transport Agent: postfix.
Stopping ftp server: proftpd.
Starting ftp server: proftpd.
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result reso
urce in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found!ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install q
uota, please take the steps described in the installation manual. Otherwise your
system is now available without reboot.
Please direct your browser to

https://mipc.domain.tld:81

and log in:
Username: admin
Password: admin
I install it for three times nad allways is the same.

Anyone have similar problem?
Anyone know howto solve it?

omniware 23rd April 2008 19:50

Resolved
 
Finally I look the error.

I think it is a bug in installation program code.

If you put on root mysql any password wich it starts with ( then the setup program broking.

Bye

GaulHahn 10th September 2008 15:29

Darn i just ran into this bug as well.

Do I have to start from scratch or is there a quick way I can fix this?

Thanks

GaulHahn 10th September 2008 15:36

Actually I think I have resolved it.

Reran mysql -h localhost -u root -p'pas(()word' ispconfigdb < db_ispconfig.sql

Used '' around the password.

Had to extract ispconfig again though after reslising the installer obvioulsy cleans it up.

If i need to do anything else that may have been broken by this please let me know.

Thanks


All times are GMT +2. The time now is 02:45.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.