HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Installation/Configuration (http://www.howtoforge.com/forums/forumdisplay.php?f=16)
-   -   Webalizer error (http://www.howtoforge.com/forums/showthread.php?t=2258)

toyito 26th January 2006 20:41

Webalizer error
 
Im having problems whit webalizer...reading some posts about a found this code:

/root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php

Whe i runnit i get:

Warning: readlink(): Invalid argument in /root/ispconfig/scripts/shell/logs.php on line 125

is this the problem??? what can i do

Regards
Hector

till 26th January 2006 20:44

Which problems do you have with webalizer?

Thats just a warning that does not matter. It wont stop the script.

The script /root/ispconfig/scripts/shell/logs.php splits the logfiles, the webalizer script is: /root/ispconfig/scripts/shell/webalizer.php and can be called with:

/root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php

toyito 26th January 2006 21:14

Thanks Till

My problem is that i cant see the stats on the web...i point to http://www.xxx.com/stats and i get a 404 error page

Hector

falko 26th January 2006 21:38

This thread might help you: http://www.howtoforge.com/forums/showthread.php?t=562

hairydog2 26th January 2006 22:10

Quote:

Originally Posted by toyito
Warning: readlink(): Invalid argument in /root/ispconfig/scripts/shell/logs.php on line 125

Just to help me with a related problem, do you have a directory called 'localhost' in your /home/www directory? I do, and I get that error message unless I do some tweaking.

toyito 26th January 2006 23:46

Hi

under /home/ i dont have a "www" folder

Hector.

Thanks Falko, i follow the steps in that thread, do i need to wait until 4:00 am?, there´s no way to to see if the problem was fixed??

Hector

falko 27th January 2006 07:24

Quote:

Originally Posted by toyito
Thanks Falko, i follow the steps in that thread, do i need to wait until 4:00 am?, there´s no way to to see if the problem was fixed??

Hector

Yes, you must wait...

toyito 27th January 2006 14:29

Thanks a lot....as i told you I foolowed the steps on thread and now all is runnig ok

Thank you Falko

Regards
Hector

sulfuric 9th March 2006 16:59

Related probem
 
Im having problems whit webalizer...reading some posts about a found this code:

/root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php
/root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizar.php

I could create my stats manually.

CRON don't execute this at 0,00-4,00, I can create my stats manually only.

I try to stop CRON, edit CRON (crontab-e) and then save and start, but don't work, only a extrange meesage on syslog

Mar 9 02:09:02 omaxserver /USR/SBIN/CRON[15263]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
Mar 9 02:09:02 omaxserver /USR/SBIN/CRON[15265]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
Mar 9 02:17:01 omaxserver /USR/SBIN/CRON[15474]: (root) CMD ( run-parts --report /etc/cron.hourly)
Mar 9 02:31:58 omaxserver -- MARK --
Mar 9 02:39:01 omaxserver /USR/SBIN/CRON[16005]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
Mar 9 02:39:01 omaxserver /USR/SBIN/CRON[16006]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
Mar 9 02:51:58 omaxserver -- MARK --
Mar 9 03:09:01 omaxserver /USR/SBIN/CRON[16742]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
Mar 9 03:09:01 omaxserver /USR/SBIN/CRON[16744]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
Mar 9 03:17:01 omaxserver /USR/SBIN/CRON[16952]: (root) CMD ( run-parts --report /etc/cron.hourly)
Mar 9 03:31:58 omaxserver -- MARK --
Mar 9 03:39:01 omaxserver /USR/SBIN/CRON[17482]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
Mar 9 03:39:01 omaxserver /USR/SBIN/CRON[17484]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
Mar 9 03:51:58 omaxserver -- MARK --
Mar 9 04:09:01 omaxserver /USR/SBIN/CRON[18221]: (root) CMD ( [ -d /var/lib/php5 ] && find /var/lib/php5/ -type f -cmin +$($
Mar 9 04:09:01 omaxserver /USR/SBIN/CRON[18223]: (root) CMD ( [ -d /var/lib/php4 ] && find /var/lib/php4/ -type f -cmin +$($
Mar 9 04:17:01 omaxserver /USR/SBIN/CRON[18432]: (root) CMD ( run-parts --report /etc/cron.hourly)
Mar 9 04:31:58 omaxserver -- MARK --

it's the error, I have perfect setup Ubuntu breeze on AMD 64.

Thanks

falko 9th March 2006 19:22

Did you run
Code:

crontab -e
as root?


All times are GMT +2. The time now is 12:02.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.