HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials

HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials (http://www.howtoforge.com/forums/index.php)
-   Tips/Tricks/Mods (http://www.howtoforge.com/forums/forumdisplay.php?f=19)
-   -   Remoting Framework beta 3 with 2.2.23 stable (http://www.howtoforge.com/forums/showthread.php?t=22484)

kextra1 18th April 2008 22:33

Remoting Framework beta 3 with 2.2.23 stable
 
Hello,

I am running ISPConfig 2.2.23 & Debian Etch 4.0

Although I haven't looked inside the .pkg file for the remoting framework beta 3, I'm not sure if that is where the problem is.....

I've enabled XML in the compile script before install...I've tried quite a few things....however in version 2.2.18 I was able to view the index page.

php -m shows that I have soap and xml....

After Browsing to https://www.mysite.com:81/remote

I get the following error:


<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

<SOAP-ENV:Body>

<SOAP-ENV:Fault>
<faultcode>Server</faultcode>
<faultactor>method '' not defined in service ''</faultactor>
<faultstring/>

<detail>
<soapVal xsi:type="xsd:string"/>
</detail>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

<!--

soap_server: entering parseRequest() on 15:04 2008-04-18
soap_server: Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
soap_server: Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
soap_server: Accept-Encoding: gzip,deflate
soap_server: Accept-Language: en-us,en;q=0.5
soap_server: Connection: keep-alive
soap_server: Keep-Alive: 300
soap_server: User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080311 Iceweasel/2.0.0.13 (Debian-2.0.0.13-1)
soap_server: got encoding: UTF-8
soap_server: method name:
soap_server: method '' not found!
soap_server: parser debug:
soap_parser: xml was empty, didn't parse!

soap_server: server sending...

-->



If anyone knows of a solution, I'd really appreciate it if you'd post :)

Thanks

-=k

grandpagenocide 18th April 2008 22:57

try beta 4, it should fix that error

http://howtoforge.com/forums/showthread.php?t=22087

kextra1 19th April 2008 01:21

Thanks...but it's a no go unfortunately :(
 
Hey GP...thanks for the quick response....

Unfortunately it's still the same error....

As I stated earlier, I have xml enabled...soap installed, etc. etc.

I'm running Debian Etch 4.0 and ISPConfig 2.2.23, PHP 5.2.0-8

I completely removed and reinstalled the beta 4 pkg you've so kindly provided and this is what I get.

<SOAP-ENV:Envelope SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

<SOAP-ENV:Body>

<SOAP-ENV:Fault>
<faultcode>Server</faultcode>
<faultactor>method '' not defined in service ''</faultactor>
<faultstring/>

<detail>
<soapVal xsi:type="xsd:string"/>
</detail>
</SOAP-ENV:Fault>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

<!--

soap_server: entering parseRequest() on 18:22 2008-04-18
soap_server: Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
soap_server: Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
soap_server: Accept-Encoding: gzip,deflate
soap_server: Accept-Language: en-us,en;q=0.5
soap_server: Connection: keep-alive
soap_server: Host: chronikal.tetic.org:81
soap_server: Keep-Alive: 300
soap_server: User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080311 Iceweasel/2.0.0.13 (Debian-2.0.0.13-1)
soap_server: got encoding: UTF-8
soap_server: method name:
soap_server: method '' not found!
soap_server: parser debug:
soap_parser: xml was empty, didn't parse!

soap_server: server sending...

-->


If you have any suggestions...let me know...thanks again...

grandpagenocide 19th April 2008 16:19

if you want me to take a peek at it Ill be free tommorow afternoon, but did you restart the ispconfig_server? /etc/init.d/ispconfig_server restart

kextra1 21st April 2008 04:48

Restarted ISPConfig & A Reboot
 
Thanks for your response,

Yes I've restarted ISPConfig and also rebooted the system entirely. I am running Debian Etch 4.0 ...could it be, that I have a package installed, or possibly that I do not have a package installed that my be causing this error?

I also completely removed the remoting framework before installing the beta 4 version.

Thanks again, for any information you may have regarding this issue...

grandpagenocide 21st April 2008 13:58

the only additional package you need is libxml2-dev if you didnt install it, apt-get install libxml2-dev

kextra1 21st April 2008 23:05

Packages installed
 
I have the correct package installed, however I also have the xml2 package installed and soap4r package installed...I'll try to uninstall these and see if it makes any difference...

Thanks for your advice!

grandpagenocide 22nd April 2008 14:09

Kextra1,
If you want I can take a look at your install, pm me


All times are GMT +2. The time now is 17:31.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.